Hello Guest it is December 05, 2021, 02:21:26 PM

Author Topic: New driver board (TB6560-4V3) steppers only work occasionally  (Read 5646 times)

0 Members and 1 Guest are viewing this topic.

New driver board (TB6560-4V3) steppers only work occasionally
« on: January 07, 2015, 05:33:57 PM »
I have a foam cutter which worked by slaving the two sides together at my school.  Sometime while I wasn't at school, it became broken.  I thought it was initially a power supply issue because all 4 fuses on the old board would instantly blow upon power up.  New power supply (Meanwell SE-200-24 (8.8A, 24V) didn't help.  So I got a new driver board to replace the old Mechatronics 4-axis bi-polar driver (no longer in production as far as I could tell).  Being cheap... I got a TB6560-4V3 (see attached manual).  I have everything hooked up in what appear to be the correct places and seem to have Mach3 hooked up correctly as well.  The lights on the board indicating a signal light up for all axis for both g-code and jogging.  In addition, the 12V and 5V lights are active.  The only light not on is the "RLY" which I think was for a spindle relay that I don't have on a foam cutter.  The trick here is that none of the steppers consistently work.  Just jogging it, probably once in every 50+ attempts a stepper will turn.  But it won't turn for more than a couple revs (but while it is turning it is smooth). Usually if it works for a one press it will also work the next couple presses.  All of the steppers (Oriental PK266-02A, 2A steppers) behave like this (both the 4 on the machine and a spare I had).  I have tried numerous combinations of different stepper speeds/steps/current/current decay settings as well as trying the board with only a single stepper in case there wasn't enough power available. 

I know that my computer is working properly as well as Mach 3 because the same system works perfectly with a small 3-axis mill.  I am really at a loss as to what could be wrong.  I have checked all the connections, nothing seems burnt or sparking, wiggling wires didn't seem to effect anything.  Could it just be a bad board or am I missing something?


Re: New driver board (TB6560-4V3) steppers only work occasionally
« Reply #1 on: January 07, 2015, 09:11:50 PM »
TB6560 are well know to be problematic and are typical Chinese junk with lousy documentation. Chinese aren't known for quality control. There is a reason they only cost $35. If you paid more than $35 you got ripped off. Sounds like you got a bad stepper driver right out of the box. Good luck with returning it or getting a replacement.

As the saying goes... you get what you pay for.

One thing you might want to check is the power supply is set for the incoming line voltage. The power supply line power can be either 120V or 220V selectable via a switch on the case. If the power supply is setup for 220V and connected to a 120V, the DC output will be  approx 9 to 12VDC not 24VDC. Most Meanwell power supplies I've seen are shipped for setup for 220V.
Re: New driver board (TB6560-4V3) steppers only work occasionally
« Reply #2 on: January 08, 2015, 10:19:56 AM »
Yeah, I had it in 120V as well as I checked the output voltage and it was 24V.  Drat, I guess I got ripped off.  Thanks.