Hello Guest it is October 19, 2019, 04:06:15 AM

Author Topic: Mach, Rutex, Yaskawa combination  (Read 3815 times)

0 Members and 1 Guest are viewing this topic.

Mach, Rutex, Yaskawa combination
« on: March 09, 2007, 09:08:43 PM »
I am struggling to make a Yaskawa servo motor and amp work with a Rutex step and dir to +/-10v converting board.  I had hoped to eventually make these work with a Campbell breakout board and Mach3.  The problem is that although I can turn the Yaskawa motor easily with +/-10v to the Vref input, the Rutex board will not cooperate.  The PC is generating step and dir signals that look good on the oscilloscope, but no J3 output occurs to move the motor.  When turn off the servo amp, the Rutex drive puts out a full + or -10v depending on which direction I passively turn the motor shaft.  I am wondering if the resolution of the motor's encoder is a problem.  I can set any level of resolution with this Yaskawa amp up to 8192 ppr.  I am running the amp and motor in speed reference mode.  The motor will jog nicely with the amp's jog feature and with an exogenous voltage input.  The tuning software does show communication with the encoder as it displays position and the steps as I passively turn the motor's shaft.  I know this is a very complex task as the hours I have spend in trial and error prove.  Hopefully, someone might be able to shed some light.

Thanks
Keith Clark  ???
Oklahoma City
« Last Edit: March 09, 2007, 09:11:34 PM by thespindoctor »
Re: Mach, Rutex, Yaskawa combination
« Reply #1 on: March 09, 2007, 09:57:52 PM »
What is the model number of the amp?  What pins on CN1 do you have the analog signal connected to?

Regards,
Scott
Re: Mach, Rutex, Yaskawa combination
« Reply #2 on: March 09, 2007, 10:07:36 PM »
Scott,

I am using 1CN pins 14 and 15, the IN-B Auxiliary input.  Pins 12 and 13 are connected.  The amp is a CACR type.

Thanks,
Re: Mach, Rutex, Yaskawa combination
« Reply #3 on: March 10, 2007, 09:56:14 PM »
Keith,

Does it make any difference if you leave pins 12 and 13 open?  Do have the P.OT and N.OT signals connected?

Also, make sure the analog signal from the Rutex is connected to pin 14 and the signal ground is connected to pin 15.

Scott
Re: Mach, Rutex, Yaskawa combination
« Reply #4 on: March 10, 2007, 11:49:49 PM »
Scott,

There are settings on the amplifier through a keyboard which tell the amplifier to ignore 12 and 13 and use 14 and 15.  The Rutex signal is connected to 14 and ground to 15 for sure. The P.OT and N.OT are not activated as this amplifier was wired without limit switches originally to that is not a problem.  One thing I am wondering is if the notPCON feature is messing things up.  Are you familiar with this feature? Now, the notPCON is open.  I think the next thing to try is to connect that pin to 24v and see what happens.  There seems to be some noise in the system possibly.

On a good note, I was able this afternoon to get the motor to move in both directions with Mach3! However, the movement is very coggy and it still does not want to move consistently but in one direction.  I will try tomorrow to switch the dir to active high and see if that makes a difference.  Lots of trial and error, but mostly error...

I have just been advised that the Rutex should be in an electrically isolated box and some caps across the power in to clean up noise.  I hope that will make a difference.
Re: Mach, Rutex, Yaskawa combination
« Reply #5 on: March 11, 2007, 09:04:31 AM »
Keith,

The PCON signal switches the drive from PI (proportional-integral) to proportional only.  The PI mode is preferred as it gives better speed control, but I don't know off hand if the signal on this drive needs to be on or off to enable this mode.  I think you should try dropping the encoder count out of the drive just to see if this helps.  You probably can drop it quite a bit without hurting your machine accuracy.  Other than that, it doesn't really sound like a problem with the drive.

Scott
Re: Mach, Rutex, Yaskawa combination
« Reply #6 on: March 11, 2007, 09:46:09 AM »
Scott,

The mode switch disable has been set to prevent the change from PI to P mode.  It seemed simpler to just eliminate this variable.

I have adjusted the encoder count from 500 to 8192 and there is not any improvement.

I hope the caps will cure the problem

As far as the encoder count goes, Mach wants a steps per inch value.  I am confused by quadrature count, encoder ppr and step multiplier.  If the encoder is set at 8192 ppr with a step multiplier of 4 the actual steps per revolution by Mach would be 2048?  If I set 2048 with step of 1, the steps per revolution would then be 2048?

thanks,
Keith
Re: Mach, Rutex, Yaskawa combination
« Reply #7 on: March 11, 2007, 11:23:29 PM »
Scott,

Do you think running in torque mode would make any difference as opposed to speed reference mode?

Thanks,
Keith
Re: Mach, Rutex, Yaskawa combination
« Reply #8 on: February 26, 2009, 03:30:59 PM »
Did you ever get this working? What are the model of your drives? CACR-SR or CACR-PR?

-Adam