Hello Guest it is December 15, 2019, 08:42:50 AM

Author Topic: THC doesn't move Z-axis  (Read 2511 times)

0 Members and 1 Guest are viewing this topic.

THC doesn't move Z-axis
« on: February 16, 2014, 08:55:05 AM »
Hi, i'm new to this forum.

I have a problem setting up Proma THC with Mach3 and thought maybe some of u could help me resolve it.

I have installed the Proma THC correctly and while running testmode on the THC i see the yellow lights flash (THC UP/DOWN) in mach3 diagnostics.

My problem is that the Z-axis doesn't move from the inputs of the THC. I can jog the Z-axis with the keyboard.

Anyone know a solution to why Mach3 doesn't move Z-axis while it clearly gets input to do so?

Thank U!
Re: THC doesn't move Z-axis
« Reply #1 on: March 01, 2016, 03:44:13 AM »
hi mate im having the same problem just woundering if you sorted it out and would have any info

Offline Davek0974

*
  •  2,580 2,580
    • View Profile
    • DD Metal Products Ltd
Re: THC doesn't move Z-axis
« Reply #2 on: March 01, 2016, 06:58:49 AM »
Do you have properly licensed Mach3 install??

THC only works on this.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: THC doesn't move Z-axis
« Reply #3 on: March 03, 2016, 02:26:55 AM »
yeh mate I have got movment now but highly doubt iv done the right thing I'm sort of guessing a lot, I cant express just how green I am at all this. but I went into -ports and pins-   -inputs-   and  right down the bottom where it says jog z axis up and down I set the same pin numbers that my THC sends to . what do you reckon is that loco!!!

Offline Davek0974

*
  •  2,580 2,580
    • View Profile
    • DD Metal Products Ltd
Re: THC doesn't move Z-axis
« Reply #4 on: March 03, 2016, 03:02:11 AM »
It **might** but I don't think you will find a Jog move is anything like a THC move - jogs use acceleration/deceleration curves, THC does not, it's just bang up, bang down and needs that due to the tiny window of time it has to operate in - the torch does not stop while the THC is adjusting the height, this is why we have the THC rate DRO - because you cannot bang an axis up and down at speed without accelerating it first so you have to use a percentage of the speed that DOES allow you to bang it up and down - usually around 20%
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: THC doesn't move Z-axis
« Reply #5 on: March 03, 2016, 05:23:52 AM »
yeh I figure as much, I have a full version and (allow THC) in mill settings is checked  and the box THC in (plugin config    ESS-v10hd2) . do I need to have anything checked in output signals , the machine runs well and I have cut a few things but just cant get this THC to respond , the THC input signals are set on active low and I can see them in the diagnostics screen

Offline Davek0974

*
  •  2,580 2,580
    • View Profile
    • DD Metal Products Ltd
Re: THC doesn't move Z-axis
« Reply #6 on: March 03, 2016, 05:37:35 AM »
Cant help with the ESS as I'm on parallel port here, no as long as you can jog the Z with the PgUp / PgDn keys on the keyboard there is no output to set.

Have you got an "Arc-Ok" signal? If yes then the "Allow THC when not in THC mode" should be unchecked I think.

Do you have a value in the THC rate DRO on the settings tab? Try 20% to start with.

You could try going into ports and pins, inputs, and flipping on "Emulated" for THC-Up & THC-Down, just for a test, this should allow you to kick the z up/down with the keyboard by pressing U & D respectively, may have to set that 'allow thc when not in thc mode'  back to on to do this but put it all back afterwards.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives
Re: THC doesn't move Z-axis
« Reply #7 on: March 03, 2016, 06:27:36 AM »
groovy I will give it all a try and see what happens