Hello Guest it is June 16, 2019, 11:33:52 PM

Author Topic: Parallel Port Address  (Read 3503 times)

0 Members and 1 Guest are viewing this topic.

Parallel Port Address
« on: February 10, 2014, 06:28:16 AM »

I have a problem in that the PC running on Windows XP does not communicate with the CNC machine.
I want to eliminate the possibility of the wrong port 1 address.

The address found via the PC control panel is 0378-037F
The Mach 3 config setting screen shows 0x378
When I try to change the setting and "apply it" it just seems to default to the 0x378 setting.

Any help appreciated.

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Parallel Port Address
« Reply #1 on: February 10, 2014, 07:18:47 AM »
That is fine.
Hood
Re: Parallel Port Address
« Reply #2 on: February 10, 2014, 11:21:12 AM »

Thanks.
 Are you saying that the two addresses are effectively the same ?

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Parallel Port Address
« Reply #3 on: February 10, 2014, 11:26:47 AM »
Yes.

Hood
Re: Parallel Port Address
« Reply #4 on: February 10, 2014, 03:42:24 PM »
As it doesnt sound like a port address, not sure what controller you are using but check out the following:
Must have at least one axis is set correctly on the Step and Dir don't forget the port setting for each.
Check:
The EStop is on the correct pin and port
The Card Enable is on the correct pin and port

The best way is to disable the Estop and make sure the card is active by using the jog controls.

What controller or breakout board are you using?

LP

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Parallel Port Address
« Reply #5 on: February 10, 2014, 04:38:05 PM »
That is the default onboard parallel port address.
Hood
Re: Parallel Port Address
« Reply #6 on: February 11, 2014, 11:55:57 AM »
Thanks for your comments.
I have just checked the parallel port cable for continuity on all pins and it's OK

The stepper motor driver is from Routout in UK. I bought it around 10 years ago and it has been fine. My trouble started a few months ago when I suspected a PC problem, but this has been checked out OK but I reloaded the Mach3 software.

There is power to the driver box and I can set limit switches using the auto set facility so the PC is connecting to Mach 3.

I think I must have a setting in the config area wrong.

The e stop is port 1 pin 10.
The X,Y & Z axes are set as specified by Routout.Could you explain the comment ref. the card enable - where is this option located ?

Any help appreciated

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Parallel Port Address
« Reply #7 on: February 11, 2014, 02:31:49 PM »
I think what is meant regards the Enable is some breakouts require an enable signal, yours mayor may not but should be in the documentation for it.
Hood
Re: Parallel Port Address
« Reply #8 on: February 14, 2014, 04:11:42 AM »

Still going thro checks.
It has been suggested that I check the output on the PC parallel port.
When I remove the parallel port cable from the driver box to access the pins I cannot operate the reset button in Mach 3.

In the config. set up for inputs it does not seem possible to de activate the e stop. I guess a safety default.
I get the message "external e stop requested" How do I override this ?

My next step would be to check the X direction pin to ground voltage whilst requesting X axis motion.

Any comments appreciated.






Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: Parallel Port Address
« Reply #9 on: February 15, 2014, 07:56:49 PM »
Change the active state of the E-Stop instead of trying to disable it.
Hood