Hello Guest it is March 05, 2021, 09:27:43 PM

Author Topic: tool path way out when loaded in Mach  (Read 3247 times)

0 Members and 1 Guest are viewing this topic.

Offline Aegir

*
  •  30 30
    • View Profile
tool path way out when loaded in Mach
« on: February 08, 2014, 04:41:57 AM »
OK, so I am really NEW.
Mr Hood, helped with my last question, and since then, 40 videos later as well, I am running good CAM software with Mach 3 post.

So to get my machine up and running, I designed a simple circle I want to do a facing operation on. I have max cut depth at 0, as I basically want to skim across the top to make sure all is well.

I am running the CAD program, and the CAM in MM.
So I designed one file where the circle was 151mm, and once uploaded into Mach, it is many times bigger than my table when I click that view.
I first suspected it may be in CM, so I went back and did the same file, but now in 15mm (just in case it is CM) and while smaller, same issue.
I do notice, that when I start Mach 3 in MM, and load the file, it goes to Inches. Then I type in G 21, and it goes back, but makes no difference to the massive work piece I have according to Mach 3.  A little frustrating in itself, as I started in MM, and expect it to stay in MM.
So even if it was 15'' for some unknown reason, it should still fit on my table.
So am at a loss here, looked for the issue, and not really finding anything of note.

It will end up being simple I am sure, but it is only easy if you know how.
Help!

Offline RICH

*
  • *
  •  7,419 7,419
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #1 on: February 08, 2014, 04:52:09 AM »
Draw in mm, cam in mm/post in mm, the machine should be configured in mm.
Don't mix units.

RICH

Offline Aegir

*
  •  30 30
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #2 on: February 08, 2014, 04:56:41 AM »
Draw in mm, cam in mm/post in mm, the machine should be configured in mm.
Don't mix units.

RICH

That is what I did. I start Mach 3, it is in MM. My drawing and post is in MM. It is stated above, that all are in MM.

I load the file, Mach 3 goes to inches! I tell it to go to MM.
But the tool path is way out of bounds.

Even if inches got in there somewhere, the current file is 15mm only, so if it became 15'', it still should fit on my table, but does not.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #3 on: February 08, 2014, 05:04:37 AM »
If you attach both your xml and the G Code file I will take a look.
Hood

Offline Aegir

*
  •  30 30
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #4 on: February 08, 2014, 05:14:55 AM »
Not sure where to find xml.
The file saved as tap.

I will find out how to upload here

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #5 on: February 08, 2014, 05:17:20 AM »
Open Mach and look lower right at the profile name you are using. Close Mach then browse to the Mach3 folder and you should find a file with that name and a .xml file extension. Copy it to your desktop and rename Aegir.xml then use the additional options button on the reply page to browse and attach the renamed file.

Hood

Offline Aegir

*
  •  30 30
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #6 on: February 08, 2014, 05:26:47 AM »
OK thanks.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #7 on: February 08, 2014, 05:33:53 AM »
The code is written in Inch units, look on line N130, it says G20, change that to G21 and it should look ok.
Hood

Offline Aegir

*
  •  30 30
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #8 on: February 08, 2014, 05:36:27 AM »
OH,

The program says MM.

OK, I will change that, thank you.
Sure I will be back.  :)

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: tool path way out when loaded in Mach
« Reply #9 on: February 08, 2014, 05:39:22 AM »
Your CAM may either be set wrong or it could be you need to edit the post processor  as it is putting out a G20 rather than a G21.
Hood