Hello Guest it is May 22, 2019, 05:33:28 PM

Author Topic: Help with soft limits please...  (Read 1649 times)

0 Members and 1 Guest are viewing this topic.

Offline Davek0974

*
  •  2,497 2,497
    • View Profile
    • DD Metal Products Ltd
Help with soft limits please...
« on: January 30, 2014, 02:23:51 PM »
Now I've finally got my table running, no plasma yet, just setting up, I am trying to figure out soft limits in mach as it's a bit to easy to jog into the limit switches.

I have an envelope of 650x650mm so I set my minimums to 0 & 0 and my maximums to 650 with a 10mm slow zone but it didn't seem to work, have I set the soft limits correctly??

Also, when I tried to re-run a previously working test code, I get a G54 error.

This is all new to me so I thought it best to ask.

Also, on a plasma table, is Z0 torch up or torch down?
My preference is for Z0 to be with the tip touching the machine table.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Help with soft limits please...
« Reply #1 on: January 30, 2014, 04:03:10 PM »
Make sure you have auto zero chosen. Also have you enabled the softlimits via the button?
Hood

Offline Davek0974

*
  •  2,497 2,497
    • View Profile
    • DD Metal Products Ltd
Re: Help with soft limits please...
« Reply #2 on: January 30, 2014, 04:27:26 PM »
Auto zero does work when I do a home-all, will double check in the morning,
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Help with soft limits please...
« Reply #3 on: January 30, 2014, 04:58:04 PM »
If you still cant get it working attach your xml  and I will see if I can find a problem.
Hood

Offline Davek0974

*
  •  2,497 2,497
    • View Profile
    • DD Metal Products Ltd
Re: Help with soft limits please...
« Reply #4 on: January 31, 2014, 01:19:54 PM »
Got it sussed now, the biggest problem was that the slow-zone was way too small, bumping it up to 50mm got it all working nicely.

The z-axis threw me a bit off course as it's all negative number but once I figured out what was happening it all clicked.

A small vid of her running...
http://www.davekearley.co.uk/LinkPics/CNCVID1.mp4

Thanks for the tips.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Help with soft limits please...
« Reply #5 on: January 31, 2014, 02:19:01 PM »
Looking good :)

Hood