Hello Guest it is May 21, 2019, 03:15:45 PM

Author Topic: Sherline Motor Troubles  (Read 3059 times)

0 Members and 1 Guest are viewing this topic.

Sherline Motor Troubles
« on: January 22, 2014, 10:24:02 AM »
Hello all,

I posted a while back in a previous thread about this machine, but this is a new problem. To summarize:

I've taken the motor driver board out of a sherline PC and attached it to a sherline XYZA set up.

I also am using a PMDX126 with a PMDX109(Output) breakout board to control a welding laser's operation, as well as a gas solenoid.

There is an iMachIII pendant being used as well to jog the table.

I'll attach my XML to this post if it helps.

At the moment I have the PMDX126/109 connected to serial port 1. Mach3 sees the Estop and all of the buttons I have attached to the board. These buttons will control things like cycle start, cycle stop, and reset. Those work just fine with OEMs and a few custom m-functions.

The sherline motors are not moving however. They will not move with a gcode or with the pendant. In the past I was able to jog the table back and forth just fine with only the sherline board plugged in to serial port 1.

When trying to jog the table the coordinates for the axis selected moves on the DRO, but the motors will not. I can hear that the motors have power, so they appear to be getting some signal from the motor controller.

I've tried switching the motor controller to port 1 and the PMDXs to port 2, but Mach3 can't see the Estop when the PMDX is in port 2.

Any suggestions would be greatly appreciated.
Re: Sherline Motor Troubles
« Reply #1 on: January 22, 2014, 01:57:01 PM »
try adjusting your motor tuning
Kenneth
Re: Sherline Motor Troubles
« Reply #2 on: January 22, 2014, 02:06:52 PM »
i had mine set to;
steps per 16000
vel   4
acc  .335

you can adjust from there
Kenneth
Re: Sherline Motor Troubles
« Reply #3 on: January 22, 2014, 02:39:13 PM »
I set the fields to what you have listed, but the motors will not turn when pressing the up or down keys.

Somebody here at work says that maybe there is a conflict between my serial port's IRQs, but I'm not sure how to change those (Or even what they are really).
Re: Sherline Motor Troubles
« Reply #4 on: January 22, 2014, 02:41:55 PM »
sorry but neither do i.
you get NO movement at all ?
mine would twitch when they were being engaged and i try to make a move.
if they're not doing that then i think it's your other board.

p.s. is the sherline board grounded ?
« Last Edit: January 22, 2014, 02:43:31 PM by Kenneth »
Kenneth
Re: Sherline Motor Troubles
« Reply #5 on: January 22, 2014, 02:57:29 PM »
The sherline board is grounded.

I'll rig up an external Estop and try the sherline board on port 1 to see if I can make it play. If it works I guess its some conflict with the serial port settings.
Re: Sherline Motor Troubles
« Reply #6 on: January 28, 2014, 01:35:58 PM »
So, I've gotten the motors running. The port I had the port installed in was dead. I've got another issue that is hopefully easy to solve. My motors are only running in the positive direction, regardless of the jogging wheel being rotated CW or CCW. Any ideas of why this could be?
Re: Sherline Motor Troubles
« Reply #7 on: January 30, 2014, 05:20:17 AM »
not sure as i have one that i have to select a direction before i job.
but that sounds like the pendant wired wrong or defective.(imho)
Kenneth
Re: Sherline Motor Troubles
« Reply #8 on: November 24, 2014, 08:25:39 AM »
Wow, I guess it has been a while since I've had time to work on this project. Now that I am though I've got a few questions again.

To update:

I'm no longer using the sherline boards to control the lathe. Instead I am using a geckodrive 540, which seems to work great.

The PMDX-126 and geckodrive 540 seem to play together nicely, but only when I use the mach3 profile that is provided by geckodrive. This would be fine except the profile doesn't seem to save any of the changes I make to it, such as port addresses, input/output assignments, plugins, etc. Any idea why it will not save this information?

I've made a seperate profile in the meantime to continue working out the bugs, but I've noticed that the motors speed is dramatically less in my custom profile than in the geckodrive profile. I've set the motor tuning to the exact same, except for the step/dir pulse which the geckodrive profile has set to 2606. My custom profile won't save that setting.

So basically, I either need to figure out how to get the geckodrive profile to save, or I need to figure out why the motors are turning slowly in my custom profile.

Any help would be greatly appreciated.
Re: Sherline Motor Troubles
« Reply #9 on: December 01, 2014, 05:25:51 AM »
i had the same issue with profiles. if i made one to use same setting, mach3 didn't
have the same settings. i HAD to use THEIR profile from the mach3 loader. even tried
to make a link with that profile but it didn't load everything. i "think" it's about the xml
AND the set file. hope this helps.
Kenneth