Hello Guest it is May 26, 2019, 09:40:12 AM

Author Topic: Slow jog.  (Read 2057 times)

0 Members and 1 Guest are viewing this topic.

Slow jog.
« on: January 22, 2014, 06:34:12 AM »
I've been adjusting the steps per value, velocity and acceleration and everything seems ok, but I do get the occasional warning saying I have one or more axis set up to operate beyond 25,000KHz. This does not appear to be an issue as I can rapid without any problem for quite some time, but there does appear to be an issue where the jog velocity drops to maybe one tenth of it's previous speed for no obvious reason. I tried rebooting the computer and checking the relevant settings, but have not been able to find a fix for this.

Any ideas?

Offline Hood

*
  •  25,826 25,826
  • Carnoustie, Scotland
    • View Profile
Re: Slow jog.
« Reply #1 on: January 22, 2014, 07:01:51 AM »
Please attach your xml and I will see if I can find a problem.

Hood

Offline Hood

*
  •  25,826 25,826
  • Carnoustie, Scotland
    • View Profile
Re: Slow jog.
« Reply #2 on: January 22, 2014, 07:37:22 AM »
The code does have G3's, the reversed arcs in front should make things fine.
Attach your xml and I will have a look.
BTW what version of Mach are you using?
Hood

Offline Hood

*
  •  25,826 25,826
  • Carnoustie, Scotland
    • View Profile
Re: Slow jog.
« Reply #3 on: January 22, 2014, 10:36:02 AM »
Sorry posted the above in the wrong thread ::) must be getting old.

Hood
Re: Slow jog.
« Reply #4 on: January 23, 2014, 06:47:04 AM »
Thanks Hood,

Version 2.6 according to the help menu. See attached xml file.

Offline Hood

*
  •  25,826 25,826
  • Carnoustie, Scotland
    • View Profile
Re: Slow jog.
« Reply #5 on: January 23, 2014, 09:47:21 AM »
I see you have lots of outputs enable and set to Port 1 Pin 0, dont think that will be the problem but really you should not have things set like that, I suggest you disable them all.

You do have the X axis set right on the 25KHz mark so maybe reduce the velocity slightly on it or maybe try the kernel at 35KHz.

Hood
Re: Slow jog.
« Reply #6 on: January 24, 2014, 04:10:53 AM »
Thanks for your advise Hood, after a little research on the forums I found the cause of the slow jog to be a triggered limit switch on my z axis. I've been having issues with false triggers caused by electrical noise and didn't realize it was a true signal, so all is now in order. Thanks again, your assistance is appreciated.