Hello Guest it is May 23, 2019, 03:34:41 PM

Author Topic: gcode Change  (Read 1943 times)

0 Members and 1 Guest are viewing this topic.

Offline kolias

*
  •  1,011 1,011
    • View Profile
gcode Change
« on: January 20, 2014, 10:43:22 AM »
Don’t know what I'm doing wrong but I want to start cutting at the top right of the table and Mach3 starts from the bottom left going up to top right and then starts the cut

My Cam produces the right code (I think) but when I load the code on Mach3, it changes line N150 to what you see on the attachement..Why?

I try to simulate the above cut from my home office and Mach3 has the same XML as my machine in the garage. Perhaps that is the problem?
Nicolas
Re: gcode Change
« Reply #1 on: January 20, 2014, 10:57:00 AM »
Hi Nicolas,
I would take a guess that's two different G-Code files and you loaded the wrong one.
Mach is not changing anything to the file when loading.

Alex
Re: gcode Change
« Reply #2 on: January 20, 2014, 10:57:53 AM »
Or he's looking at machine coordinates?

Regards,
Ray L.
Regards,
Ray L.
Re: gcode Change
« Reply #3 on: January 20, 2014, 11:01:28 AM »
Look at line N120 it's different, so two different files pretty shure.
Alex
Re: gcode Change
« Reply #4 on: January 20, 2014, 11:07:11 AM »
Nicolas,
if you are not shure where to search run the PP again in MCam with a different file name for the G-Code.
Alex

Offline kolias

*
  •  1,011 1,011
    • View Profile
Re: gcode Change
« Reply #5 on: January 20, 2014, 02:01:50 PM »
Kind of weird problem but I did have the same file. What I did I deleted the gcode file and regenerated the code in Mastercam with a different name and now when I load the code into Mach3 it works well

Thank you
Nicolas