Hello Guest it is May 24, 2019, 01:42:00 PM

Author Topic: limit swtich not hooked up but still getting triggered anyways  (Read 1843 times)

0 Members and 1 Guest are viewing this topic.

limit swtich not hooked up but still getting triggered anyways
« on: January 18, 2014, 05:50:28 PM »
I had a problem similar to this before I had non shielded wire on the limit switches. If I remember correctly I changed the debounce and the problem went away.

Not the case this time. the limit switch activated a couple times when running code and then it totally stopped. I can't get the limit switch error to reset at all. router turned off reset computer everything.

This has been a very healthy machine for the past two years with few problems. The motion controls came from build your own cnc. is there a chance my b.o.b. is toasted?



Online Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: limit swtich not hooked up but still getting triggered anyways
« Reply #1 on: January 18, 2014, 06:04:40 PM »
You say the limit is not hooked up but is it still enabled in Ports and Pins? If so disable it.
Hood
Re: limit swtich not hooked up but still getting triggered anyways
« Reply #2 on: January 18, 2014, 06:21:03 PM »
Thank you, I did not think of that, I will give it a try.


If it works where should I begin looking for the problem?

This machine has ran so well the past few years that I have forgotten how to trouble shoot it :D

Online Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: limit swtich not hooked up but still getting triggered anyways
« Reply #3 on: January 18, 2014, 06:33:59 PM »
Well if your switch is a normally closed switch then I would put a jumper in instead of the switch and see if the problem still happens. If it doesnt then it would suggest the switch or wiring is the problem. If it still happens then it is from the Bob inwards that the issue is.
Hood
Re: limit swtich not hooked up but still getting triggered anyways
« Reply #4 on: January 18, 2014, 06:43:56 PM »
Thank you for the help. I got the limit switches turned off and the motion controls are working again. I will start working into the problem as you have suggested.

Online Hood

*
  •  25,816 25,816
  • Carnoustie, Scotland
    • View Profile
Re: limit swtich not hooked up but still getting triggered anyways
« Reply #5 on: January 19, 2014, 04:01:01 AM »
Most likely a switch problem, spring gone weak and switch bouncing with vibration.

Hood