Hello Guest it is June 14, 2021, 08:48:35 PM

Author Topic: 4th Axis (B) is not homing  (Read 4380 times)

0 Members and 1 Guest are viewing this topic.

4th Axis (B) is not homing
« on: January 16, 2014, 10:00:41 PM »
Hi all! 

I have a gantry machine with the A axis slaved to the Y.  I just hooked up a 4th axis (B) with a limit switch and got it all set up in mach so far as I can tell, but when I ref all home it does not move. The B axis home switch is set up in ports and pins/ inputs.  It tests good on the diagnostics screen when actuated. I can jog and control the axis just fine.

Does anyone have any idea why this isn't working?


Offline kolias

  •  1,011 1,011
    • View Profile
Re: 4th Axis (B) is not homing
« Reply #1 on: January 16, 2014, 10:59:57 PM »
I will assume that the B has been enabled in the Ports & Pins Menu (B++ and B Home) including the Homing / Limits Menu all under the Config Menu
Re: 4th Axis (B) is not homing
« Reply #2 on: January 17, 2014, 12:35:37 AM »
Yes, those have been set up.
Re: 4th Axis (B) is not homing
« Reply #3 on: January 17, 2014, 04:37:12 AM »
B and C axis will not be homed by the  "ref all home" button in the standard screenset.
Edit the  "ref all home" button with the ==> Operator  ==> Button Script Editor and ad   DoButton( 26 )
should work
just a thought
Re: 4th Axis (B) is not homing
« Reply #4 on: January 17, 2014, 08:05:35 AM »
That sounds great! I'll give it a try right now.
« Last Edit: January 17, 2014, 08:17:48 AM by shapeshaver »
Re: 4th Axis (B) is not homing
« Reply #5 on: January 17, 2014, 08:34:17 AM »
That didn't work. Maybe I don't have something set up right for the axis in Mach. I have attached my XML file. If anyone would like to take a look at it, I would appreciate it!

By the way, I have both a C rotary axis as well as this B rotary axis.
Re: 4th Axis (B) is not homing
« Reply #6 on: January 17, 2014, 09:13:57 AM »
You can home axis' individually from the Diag. screen.
Did you try that ?
Your xml won't load here. It jams my pc.  :P

Re: 4th Axis (B) is not homing
« Reply #7 on: January 17, 2014, 09:31:42 AM »
B Home isn't enabelt.
Re: 4th Axis (B) is not homing
« Reply #8 on: January 17, 2014, 10:10:31 AM »
Um, no I didnt try that. In fact I forgot that was even there. I must have seen that there many times but it just didn't register...kind of a "cant see the forest for the trees scenario".  Thank you Overloaded for the heads up on that!

Results: When I pressed the Ref B button the motor moved a small increment and stopped like it had homed. I jogged the axis different directions and tried re-homing it, but with the same behavior of moving a small increment and then stopping as if it was homed. There was no indication of the home switch LED lighting up so I figured it had to be something else. When I jog the axis I noticed the LED would light up as it passed the switch but it would flicker sporadically on occasion as well. I had used an RJ45 breakout board (http://www.cnc4pc.com/Store/osc/product_info.php?products_id=213) at both ends of a single CAT6e (fully shielded) cable to carry the step, direction and 5V signals for the stepper drive as well as one wire from the switch from the rotary axis to the Smooth Stepper board. I figured this would allow me to easily setup and remove this B axis from the table. At the RJ45 breakout board on the rotary axis end I had tied the 5V logic supply for the drive to the other side of the switch so I wouldn't have to run two 5V lines through the CAT6e cable.  While a CAT6e cable is fully shielded, I don't think the individual pairs inside the cable are shielded from each other and I was getting the step signal interfering with my switch signal. So I ran a separate 2-wire cable from the switch directly to the smooth stepper breakout board. one wire for 5V and the other for the NO switch side.

It works! Now both the "Ref B" button on the Diagnostics page and the "home all" button on the Program Run page work. I will use two more RJ45 breakout boards and run a dedicated Cat6e cable for the home switch so I can have the ease of use while keeping the two cables and their signals RF interference isolated from each other.

Thanks cncalex for the button mod directions, it did work after all!

Offline simpson36

  •  1,369 1,369
    • View Profile
Re: 4th Axis (B) is not homing
« Reply #9 on: January 20, 2014, 08:15:30 AM »
Couple tips on 4th axis homing;

*There is a cat cable that has each pair separately shielded. I don't recall the designation at the moment, but it is not uncommon stuff to find. I have been using it for about a year now with excellent results. You are better off running a separate cable as you did, but the separately shielded pairs is a worthwhile extra expense for anyone buying new cable.

*Consider running home and limit switches at 12V or 24V for a high level of immunity.

*A freebee fix that might solve 'spooky' false triggers is to simply run the signal 'backwards'. In your scenario, likely the home signal wire was picking up enough induced power to trigger the BOB. It may take only 3V and tiny current to exceed the 'high' threshold of an input pin, however, if you arrange for a full 5V signal to be 'OFF' and grounding that 5V to be 'ON' (a.k.a. active low), you build in a great deal of immunity because no amount of induced power will be able to trigger the signal pin and it is not possible to induce ground . . . . so far as I know anyway.

Also pay attention to the debounce setting in Mach, particularly if you are using a mechanical switch.