Hello Guest it is May 21, 2019, 03:08:25 PM

Author Topic: What is wrong with my cutter comp!?!  (Read 2134 times)

0 Members and 1 Guest are viewing this topic.

What is wrong with my cutter comp!?!
« on: January 16, 2014, 10:08:21 AM »
Simple program, just a rectangle, with lead in/out line and arc just as I would do on a Fanuc control.  Most of my results have been that the control just stops, doesn't know what to do on the entry to compensation.  This one is really strange, it is like it is cancelling/applying compensation on every line. 
I have "advanced compensation analysis" in ports & pins unchecked.  With it checked no compensation happens.
Can't figure this one out, need help please!

%
O0000(CUTTER COMP)
(MATERIAL - ALUMINUM INCH - 2024)
( T1 |  1/2 FLAT ENDMILL | H1 | D1 | CONTROL COMP | TOOL DIA. - .5 )
N100 G20
N102 G0 G17 G40 G49 G80 G90
N104 T1 M6
N106 G0 G90 G55 X-6.1969 Y.0015 A0. S1069 M3
N108 G43 H1 Z.25
N110 Z.2
N112 G1 Z0. F25.
G90 G91.1
N114 G41 D1 Y.5015 F30.
N116 G3 X-6.6969 Y1.0015 I-.5 J0.
N118 G1 X-8.4952
N120 Y-3.0856
N122 X-4.8986
N124 Y1.0015
N126 X-6.6969
N128 G3 X-7.1969 Y.5015 I0. J-.5
N130 G1 G40 Y.0015
N132 Z.2 F40.
N134 G0 Z.25
N136 M5
N138 G91 G28 Z0.
N140 G28 X0. Y0. A0.
N142 M30
%
Re: What is wrong with my cutter comp!?!
« Reply #1 on: January 16, 2014, 07:10:31 PM »
Remove the G91 command from line N138, it is senseless anyway.
Alex
Re: What is wrong with my cutter comp!?!
« Reply #2 on: January 16, 2014, 09:05:25 PM »
Pretty sure Fanuc requires the G91, so force of habit.  Don't know what that has to do with the question though.
Re: What is wrong with my cutter comp!?!
« Reply #3 on: January 17, 2014, 04:19:10 AM »
My pointing was regarding Mach3 not Fanuc. Mach can't handle the G91 in the same line as G28 what is affecting the toolpath.
Was the rotated toolpath intended?
I prefere to do the lead in move for G41/42 in a right angle ( 90 degree )  to the next move.
eg.

G0X1Y0Z2(Tool 0.5 ")
G0Z0.2
G41G1Y-0.5D1F50
G1X1.5
G3X2Y0R0.5
G1Y2
X-2
Y-2
X2
Y0
G3X1.5Y0.5R0.5
G1X1
G40G1Y0
G0Z2
M30
%

just a thought
Alex
Re: What is wrong with my cutter comp!?!
« Reply #4 on: January 17, 2014, 07:49:43 AM »
Tried removing the G91, and added a perpendicular lead in.  No luck, still rotated like the picture above.  The toolpath is intended to be rectangular.  The rotation changes based on the tool diameter I enter.  Somehow it is like it is re-compensating on every line.
N100 G20
N102 G0 G17 G40 G49 G80 G90
N104 T1 M6
N106 G0 G90 G55 X-6.7 Y.0015 A0. S1069 M3
N108 G43 H1 Z.25
N110 Z.2
N112 G1 Z0. F25.
N114 G41 D1 X-6.1969
G1 Y.5015 F30.
N116 G3 X-6.6969 Y1.0015 I-.5 J0.
N118 G1 X-8.4952
N120 Y-3.0856
N122 X-4.8986
N124 Y1.0015
N126 X-6.6969
N128 G3 X-7.1969 Y.5015 I0. J-.5
N130 G1 G40 Y.0015
N132 Z.2 F40.
N134 G0 Z.25
N136 M5
N138 G28 Z0.
N140 G28 X0. Y0. A0.
N142 M30
Re: What is wrong with my cutter comp!?!
« Reply #5 on: January 17, 2014, 07:58:30 AM »
Figured it out.  I turned the "advanced compensation analysis" back on.  It wasn't doing anything with the original toolpath, appears to be working now.  Thanks for the help.
Joe
Re: What is wrong with my cutter comp!?!
« Reply #6 on: January 17, 2014, 09:06:44 AM »
No probs, glad you got it working.  :)
Alex