Hello Guest it is October 19, 2019, 04:04:22 AM

Author Topic: Position and direction problems on all axis only with Slow Jog Percentage  (Read 2070 times)

0 Members and 1 Guest are viewing this topic.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Hi all! This is my first time on the Forum, hope to be able to concisely explain my problem and not waste people´s time. I´ve checked the Forum for similar problems but cant find anything.
I´ve been 3D milling polistirene for 2 months at “normal” feed-rate perfectly, (“normal” for my home-built cnc machine being 1875mm/minute) using g-codes from MESHCAM and recently DESKPROTO, and want now to use CAMBAM to mill aluminium NEMA plates  for a bigger, stronger router, and as my home built router is not very strong, So I´ll need to use quite slow feed rates, which is fine by me.
So, to the point:
If I set the Slow Jog Percentage DRO to 3% or lower, and manually jog  in a +X direction, all works well…the tool moves  at the same rate/distance as the DRO.
However, if I jog in a –X direction, the tool does not keep up with the DRO…if the DRO says 20mm of movement, the tool has only moved about a third of that.
In the Y axis, again at 3% or lower in Slow Jog Percentage, whatever direction I jog, the tool moves the in same direction, always – .
 If I jog in a –Y direction, the tool and DRO are equal. If I jog in a +Y direction, the tool as well as going in the wrong direction, only goes about half the distance the DRO reads.
In Z, similar to X…..in  – direction (down) the DRO and actual distance travelled is the same…in + direction (upward) it loses position.
Its as if the motors at these low speeds don’t have the torque necessary, to do the job, as well as having direction problems.
Attached is xml file.
I´ve tried changing kernel speed , and also step and direction pulse width in the motor setting, all to no avail.
My PC has XP sp3, 1.67Ghz and 2.25GB Ram., and a www.cnc-robotica.com USB interface.
My MACH is licensed,  and is Version R3.043.022.
Many thanks in advance,
Frank

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
What motors and drives are you using? My guess would be resonance is causing the motors to lose steps.

Also, you should be able to cut aluminum at 1500mm/min. Just set you're spindle to about 10,000-12,000 rpm. Use a single flute "o" flute tool for aluminum, and take shallow cuts, about 0.25mm/pass
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Tweakie.CNC

*
  • *
  •  7,950 7,950
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Hi Frank,

It's a long shot but try selecting Sherline 1/2 Pulse Mode (Config ; Ports & Pins) apply, do a restart and see if that makes a difference.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline Frank1959

*
  •  34 34
  • Do it, it´ll free your mind.
    • View Profile
    • Monumental Sculpture
Hi Tweakie, hi Ger,
I tried the Sherline 1/2 pulse mode, no improvement, but it was worth a try ; )

Ger, your telling me that alu could be milled at much higher speeds than I was trying ( probaby out of beginners fear of wrecking the tool...single flute, btw, as you suggested, and at 30.000 revs) prompted me to try faster.

So I´ve just done a cut perfectly at F= 150, in CAMBAM, 0.20mm/pass, spiral entry at .5º to help the tool do its job,  with no apparent chatter and all axis on spot. I will later try at double that speed, and increase to .3mm per pass, until I find the machines "limits", which I´m sure are not far off, lack of rigidity being one sure obstacle, plus small steppers (Chinese, only visible reference on the invoice from a local importer who gives a good garantee is "23HS8425") with probably very low torque for any serious milling in metal.
Drivers also Chinese.

Ger, when you say resonance, do you mean mechanical or electrical/electronic? Any ideas about resolving it if that were so?

On principal, I can easily get round the problem with adequate feed rates. Still, it would close the circle perfectly if anyone could point the finger in the right direction as to why this happens.  How the problem stiil effects things is in not being able to set the Z axis to zero on the surface of the material, as my method up to this has been the use of a multi-meter on resistance scale, connected to both tool and aluminum plate. I jog down the Z axis with Slow Jog Percentage at 1%, and for really fine tuning at .1%, until the meter reads contact.* But as things are, the Z axis only goes in one direction, down ,  at that percentage rate, no matter what direction key I touch. Baffling!

Many thanks to both of you for such prompt answer and useful feed back. This forum is wonderful...

Frank.

PS: Hope both of you get to read my reply, still not too clear on how to answer individually : (


*Still havent had time to configure auto tool zero in MACH...it´ll come! On that subject, Ger, I´ve seen references on other sites e.g. http://www.mycncuk.com/forums/project-showcase/4670-tool-height-setting-probe-mach3-solution.html to something (a screen??) you´ve done that eases the whole configuration / settup of  tool zeroing, I´ve save the link for when I eventually get round to it.