Hello Guest it is August 25, 2019, 10:35:35 AM

Author Topic: Consistent stepper clunking. All axis' all the time  (Read 4449 times)

0 Members and 1 Guest are viewing this topic.

Consistent stepper clunking. All axis' all the time
« on: December 28, 2013, 07:40:49 AM »
Hi all,
I've just put together my own CNC machine ad still working through a bunch of issues. The biggest one at the moment is clunking of the steppers. By clunking, I mean the sound they make when you power your PC up while the steppers are powered and connected through the driver. To keep things simple, I have run all tests with nothing connected to the stepper motor shafts.

Here's my setup: Gecko 540 driver, Mach3, Windows XP, Intel 3.0gHz, 2GB RAM, nVidia 9500GT, on-board parallel port, USB keyboard/mouse. No wireless/bluetooth cards, no other peripherals.

Here's a list of things I've tried:
  • Fresh Windows XP install with only Mach3 installed
  • Windows switched to Standard PC mode.
  • BIOS parallel port settings changed to Bi-directional, EPP and ECP.
  • Sherline 1/2 step mode enabled and disabled
  • Stepper motor velocity, acceleration set to really low (10 and 10)
  • step pulse/dir pulse set to 1/1. 2/2. 3/3, 4/4, 5/5
  • I kept the steppers spinning while I unplugged the USB cables... there were more clunks at the time they were disconnected but the clunks were still happening after disconnecting.

I have yet to narrow down the timing of the clunks. From my experience though, the faster they spin, the more frequent the clunks. Also, each stepper clunks at different times when they're all running together... however when I slave two together their clunks are in sync.

I'm going crazy trying to figure out how to solve this problem. My next steps are to try Windows Vista, then try Windows 7 and lastly, find an old PC with parallel port and put Windows XP on it.

Does anyone have any other things I can try? I really want it working on the current PC because it's quite beefy and I plan to use it for my garage PC as well as my controller box. Is it worth trying it on Vista or will that be a waste of time?


Thanks for your help.
Re: Consistent stepper clunking. All axis' all the time
« Reply #1 on: December 28, 2013, 10:00:36 AM »
I have a Gecko 540. The clunk is normal when powering up the power supply. The motors are being locked into position. Unplugging the USB while the motors are spinning will cause the 540 to lose command signal inputs and do strange things. I highly advise NOT doing this. Download the Gecko 540B xml file from their site and install it. It will set Mach 3 for the gecko driver.

Post you XML setting file so I can check your settings. Sounds like your settings are messed up.
Re: Consistent stepper clunking. All axis' all the time
« Reply #2 on: December 28, 2013, 05:29:11 PM »
Hi geh,

I probably should've worded it better. I understand the clunking noise is normal at start up, but that clunking noise is constant during normal operation which I'm pretty sure is the reason for my machine's random screw ups.

I downloaded a G540.xml a while back which I'm using but I've also tried the two I found on site this morning. The clunking noise is there for all 3 config files (completely unmodified as well).

I've attached the one I've mainly been testing with.


Thanks

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: Consistent stepper clunking. All axis' all the time
« Reply #3 on: December 28, 2013, 05:33:32 PM »
Quote
clunking noise is constant during normal operation


One cause could be a bad signal being generated by the PC. But would need to hear the sound.
Clunking to you may be tapping to me.............. ;)

RICH
Re: Consistent stepper clunking. All axis' all the time
« Reply #4 on: December 28, 2013, 09:49:46 PM »
You're right Rich, I really didn't know how to explain the noise.

To throw a spanner in the works... I got hold of an older PC... it's a 2.4GHz single core PC (compared to the 3.0GHz Xore 2 I've been using) and there's no clunking! It's definitely the newer PC.
Re: Consistent stepper clunking. All axis' all the time
« Reply #5 on: December 28, 2013, 10:22:18 PM »
What mfg is the PC that is making the stepper clunking? Dell Optiplex series is rumored for having difficultly running Mach 3.

One thing I did see in the XML file is the watchdog timer is turned on and the look ahead is set for 20 lines. I set my look ahead to 400 lines and watchdog timer is off. I found out early on the watchdog would cause problems.
Re: Consistent stepper clunking. All axis' all the time
« Reply #6 on: December 28, 2013, 10:30:11 PM »
also, have seen where a previously installed printer is still fiddling with the port.
polling or such. files in que maybe. deleted all associated printer stuff and all got better.
Russ
Re: Consistent stepper clunking. All axis' all the time
« Reply #7 on: December 28, 2013, 10:41:34 PM »
The motherboard is a MSI P43 Neo. I'm not quite sure on the history of the computer unfortunately. I'll try the things you guys have mentioned.

Offline RICH

*
  • *
  •  7,351 7,351
    • View Profile
Re: Consistent stepper clunking. All axis' all the time
« Reply #8 on: December 28, 2013, 11:38:02 PM »
Quote
Dell Optiplex series is rumored for having difficultly


I had to use a SS with my Dell to make things work. The signal from the Dell had "ringing" / another siganl riding on the pulse stream.
The stepper sounded like somebody was just tapping the metal case with a mallet. Also I couldn't get more than about 10 IPM out of it....it just plain sucked!
I solved that problem by having a PC made up and dedicated to CNC. Never know and sometimes one could just learn to hate PC's. :)

RICH
 

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Consistent stepper clunking. All axis' all the time
« Reply #9 on: December 29, 2013, 08:27:03 AM »
In the bios, disable C1E or EIST if you have them. Also, disable any unused hardware in the bios.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html