Hello Guest it is May 26, 2024, 02:18:02 PM

Author Topic: axis setup Poxxon MF70  (Read 5648 times)

0 Members and 1 Guest are viewing this topic.

axis setup Poxxon MF70
« on: December 23, 2013, 04:54:02 PM »
Hi guys,

I am in the pocess of converting my MF70 micro mill to CNC.
I've got all the steppermotors wired up and working.
However the leadscrew for the Y axis is counter clockwise, I've read all through the manuals of both pokeys and mach3. Mach3 manual isn't much help since it only describes how to setup the LPT ports&pins.
So how can I reverse my y axis in MACH3????? I even did a search on the forum here.
I came across a post, about a mf70 conversion as well, Had the same problem, but did not find any solution in the post, except for the comment to switch the stepper motor wires around.
Is this the only possibility to reverse an axis diection or are there other ways to go about it.
I once tried to reverse my x axis in the homing and limit switch config screen. It only switch motion direct during homing sequence, and by the way almost went through the stop. Thank you E STOP!!

So my question is: what do I need to do to reverse my Y axis?

Thanks in advance for any help and off course happy holidays!!!!
Re: axis setup Poxxon MF70
« Reply #1 on: December 23, 2013, 06:09:07 PM »

Offline NeoTO

  •  504 504
    • View Profile
    • PoLabs
Re: axis setup Poxxon MF70
« Reply #2 on: December 24, 2013, 12:06:06 AM »
Two options:
- change A and B coil wiring for your y-axis stepper on the stepper driver
- use cncalex's hint
www.poscope.com home of PoKeys USB HID, IO, USB, Ethernet controler and PoScope USB PC oscilloscope
axis setup Poxxon MF70
« Reply #3 on: December 24, 2013, 04:48:43 AM »
Alex and Matevz!

Thanks for the fast reply.
Will try the options, hope I can find some time today to see what will work.

Happy holidays!!

Verzonden vanaf mijn iPhone met behulp van Tapatalk
axis setup Poxxon MF70
« Reply #4 on: December 28, 2013, 09:07:32 PM »
Hi Alex and Matevz,

Finale got around to working the problem with my reversed y Axis.
Alex your hint did not work unfortunately, but Thanks many Thanks for the advise!,
Matevz, I swapped the wires and that fixed the problem!!!
With respect to the hint Alex gave; switching the state of the dir low active in the ports and pins menu, did not work.
I seem to remember reading in the pulse engine manual somewhere that the pokeys plugin disregards that option, but was not able to find where in the manual. Can you Confirm that?

Finally today I ran my first self generated Gcode, looks like everything is behaving the way it should!
Tomorrow I 'll run the same project in plywood, to see if it comes out allright.

Thanks again for the support, I am very happy with the support I am getting here!
Pokeys Rules!

Kind regards,


Verzonden vanaf mijn iPad met behulp van Tapatalk
(No subject)
« Reply #5 on: December 31, 2013, 01:51:45 PM »
Setting dir low worked for my MF70. Swapping the wiring is just as good a solution though.