Hello Guest it is August 20, 2019, 10:38:40 AM

Author Topic: Motors do not turn continuously  (Read 2721 times)

0 Members and 1 Guest are viewing this topic.

Motors do not turn continuously
« on: December 22, 2013, 01:36:47 PM »
On continuous jogging mode, while I am holding down an arrow key, my motor turns only for a little bit before it stops, and once it is stopped, the motor is still making the noise as if it is turning. Similarly, if I type in a G-code, for example X100, the x-axis motor turns only for a little bit before it stops, even though the reading on the screen is still changing and the motor is still making a noise as if it is turning. What is going on? Is it a setting/configuration issue or a hardware issue, and what correction should I do?

By the way, on step mode, when I hit an arrow key once, the motor does turn one complete step.

I am using Mach3 running in windowsXP, and I use a TP6560 4-axis driver board, 3 Nema 17 motors (xyz only) on a 7x7 zen toolworks kit.

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Motors do not turn continuously
« Reply #1 on: December 22, 2013, 02:33:11 PM »
   Continuous jogging mode should be just that, continuous.

   What is your motor tuning set to?

   Is it a 1.8 degree stepper or .9? Could it be the stepper stalling?

   Have you ever had this combo working before? Do you have any prior experience with Mach3 and or motion control?

   What voltage are you running the TP6560 on? (is it a TB or TP?)

   Are you saying the stepper makes 1 revolution or 1 step if you hit the key once? If it is a step, how are you measuring it?

   Do you any micro stepping value set or is it adjustable?
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Motors do not turn continuously
« Reply #2 on: December 22, 2013, 02:44:32 PM »
As Fastest says it sounds like your motors are stalling, reduce your accel and Velocity and make sure your steps per unit are set correctly.
Hood
Re: Motors do not turn continuously
« Reply #3 on: December 22, 2013, 03:02:32 PM »
Thanks for the fast response Fastest 1 and Hood! I don't have any prior experience in Mach3 and this is my first CNC router kit project .. Nor have I very familiar with stepper motors and sorry for the confusions ..

  Continuous jogging mode should be just that, continuous.

   What is your motor tuning set to?
for all 3 axes, I used:
Steps per: 1280, Velocity (mm/min): 400, acceleration (mm/sec^2): 125, G's is 0.3237738, step pulse 1-5us: 0, dir pulse 0-5: 0


   Is it a 1.8 degree stepper or .9? Could it be the stepper stalling?
It is a 1.8 degree stepper. I'm not sure what is a stepper stalling?

   Have you ever had this combo working before? Do you have any prior experience with Mach3 and or motion control?
No. I don't have any prior experience ..

   What voltage are you running the TP6560 on? (is it a TB or TP?)
TB6560 (http://www.shapeoko.com/wiki/index.php/File:HY-TB4DV-M_Ebay_CNC_Controller_4-axis.pdf)
Sorry for the typo!


   Are you saying the stepper makes 1 revolution or 1 step if you hit the key once? If it is a step, how are you measuring it?
Now after I looked up wiki .. no I didn't meant a step ..
In step mode, if I start with X at 0, and I hit the arrow key once, the motor continuously turns until X reaches 1. So I meant ,it completes 1 unit of movement, not 1 step. Since I set the units to be mm, I guess it should have turned 1 mm distance?


   Do you any micro stepping value set or is it adjustable?
I don't quite understand this question .. where is this setting?

If motor tuning is not set correctly, how should I modify them? Are there any equations to follow or should I just guess and try?
« Last Edit: December 22, 2013, 03:06:24 PM by joexusun »

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Motors do not turn continuously
« Reply #4 on: December 22, 2013, 03:30:52 PM »
   Thanks for the reply to the questions. Dont take it personally, CNC and Mach 3 are complicated and it will take a little while to become familiar with the settings.

   You didnt state the voltage but I am guessing 24vdc.

   Are the steppers installed on the router?

   You are running this off of a computer with a parallel port, correct?

   The machine moves 1 unit (1mm in your case) during a keystroke? (just for your information, the size of the step is adjustable in increments x1, x10, x100, x1000. Access these variables by pressing the "Tab" key. A flyout will appear.)

  My first suspicion is that the accel is too high, it will be under motor tuning. Change the level (accel not velocity) in half and see what happens.

  Maybe a little more info too. You say router? Ball screws or belts? What is the gearing ratio? or how many turns to travel 1 unit?

   Also the micro stepping value. (this might be fixed on that controller, I will read the manual quickly)
« Last Edit: December 22, 2013, 03:32:24 PM by Fastest1 »
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Fastest1

*
  •  927 927
  • Houston, TX
    • View Profile
Re: Motors do not turn continuously
« Reply #5 on: December 22, 2013, 03:45:26 PM »
The micro stepping is adjustable. It can be 1, 1/2, 1/4, 1/8 or 1/16. It is also odd that they recommend the 35000Hz instead of the 25000Hz Mach recommends. It will work I am just not sure why Mach recommends the lower setting.
I want to die in my sleep like my grandfather, not like the passengers in the car! :-)

Offline Hood

*
  •  25,849 25,849
  • Carnoustie, Scotland
    • View Profile
Re: Motors do not turn continuously
« Reply #6 on: December 22, 2013, 05:05:32 PM »
You should ideally set the kernel in Mach to whatever you require and no more. The higher you set the kernel the more overhead it takes and often it will cause issues if you go too high as your computer does not have the time to do anything other than pulsing. Obviously that is all dependant on the computer but generally best to keep as low as you can.
Hood