Hello Guest it is July 11, 2020, 11:27:52 PM

Author Topic: New download will not run  (Read 3136 times)

0 Members and 1 Guest are viewing this topic.

Offline cfell

*
  •  27 27
    • View Profile
New download will not run
« on: November 24, 2013, 04:38:33 PM »
I have two licensed seats of Mach running on different machines.  Today I downloaded a new "demo" copy to a third (actually tried a XP and a W2000).  In each case the software loaded and appears normal however I can't get either to test.  I have entered commands on the MDI and loaded a program.  Neither execute.  Driver test runs good, diagnostics reports nothing. I can enter values in MDI such as 5.0 for X and it takes but button will not zero.  Simulate program run works.  What am I missing.
Thanks in advance.
Charlie

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: New download will not run
« Reply #1 on: November 24, 2013, 04:47:31 PM »
You have the axes enabled in ports and pins?
Hood

Offline cfell

*
  •  27 27
    • View Profile
Re: New download will not run
« Reply #2 on: November 24, 2013, 05:03:18 PM »
Hood,  Yes X,Y,Z are green (enabled), all other choices on that screen are red. I accepted the default pin selection 2,3,4/6,7,8.  The reset button is bordered with green.  I attempted to change settings on Estop however it returns to enabled (green) even if I change it. 
Charlie

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: New download will not run
« Reply #3 on: November 24, 2013, 05:05:53 PM »
Change the active state of the E-Stop and that will allow you to take Mach out of Reset.
Hood

Offline cfell

*
  •  27 27
    • View Profile
Re: New download will not run
« Reply #4 on: November 24, 2013, 05:28:45 PM »
If I click on the green enabled check and press enter it changes to red.  When I click apply then exit and return it is green again.  I have tried all combinations of active state and emulate in conjunction with the green enable and no joy. This occurs with no cable on the computer as well.

Charlie

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: New download will not run
« Reply #5 on: November 24, 2013, 05:38:26 PM »
The E-Stop is always enabled, Mach will not allow you to disable it as it is mandatory to have an E-Stop. You can trick it into thinking it has an E-Stop by changing the active state to Active Low and that will allow you to Reset Mach.
Hood

Offline cfell

*
  •  27 27
    • View Profile
Re: New download will not run
« Reply #6 on: November 24, 2013, 05:45:06 PM »
It was active low as default.  It is currently set at active low.  I am able to reset Mach and see the green border around the reset button however going to the mdi screen and entering g00 x5 does nothing.

Charlie

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: New download will not run
« Reply #7 on: November 24, 2013, 05:51:18 PM »
attach your xml please, that will be the quickest way for me to find the problem if I can :)
Hood

Offline cfell

*
  •  27 27
    • View Profile
Re: New download will not run
« Reply #8 on: November 24, 2013, 06:00:08 PM »
Here it is.  I would consider reinstalling Mach if this wasn't happening on two different computers.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: New download will not run
« Reply #9 on: November 24, 2013, 06:03:54 PM »
You have the Jog Control switched off.
Hood