Hello Guest it is October 19, 2019, 04:19:11 AM

Author Topic: Another G-Code Loading Problem  (Read 3456 times)

0 Members and 1 Guest are viewing this topic.

Another G-Code Loading Problem
« on: February 28, 2007, 12:05:11 AM »
Greetings,

I am having some difficulty loading a complex G-Code file created from a line drawing using LazyCam.  It looks ok in Mach3 on my CAD/CAM system but fails to load correctly on my machine controller.  The attached pictures show what I am seeing on each of these systems.

I have checked the IJ Mode and it seems to be set correctly (at least changing it didn't make any difference).

Any ideas would be greatly appreciated.

Bob Segrest
Re: Another G-Code Loading Problem
« Reply #1 on: February 28, 2007, 08:56:13 AM »
I see the error with the Arc's...
There are no Arc's in the program  ;)  if you would like to look for arc's in a program look for G2 or G02 and G3 or G03

Hope that helps
Brian
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Another G-Code Loading Problem
« Reply #2 on: February 28, 2007, 09:05:48 AM »
Hello Brian,

Please forgive my ignorance in advance.....

Are you telling me that Mach3 doesn't support Arcs or that LazyCam some how left the Arcs out of my G-Code?

Why does the same G-Code file appear to load correctly in my Mach3 test environment and then NOT appear to load in the production Mach3 environment?

Shouldn't they both appear the same (good or bad)?

I appreciate your assistance in getting me through the knot holes...

Bob
Re: Another G-Code Loading Problem
« Reply #3 on: February 28, 2007, 09:11:47 AM »
Looks to me like you need to move your license file over to your mill ;)

And Yes mach3 and Lcam will do Arcs if they are in your drawings... HPGL's don't have Arcs...
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com
Re: Another G-Code Loading Problem
« Reply #4 on: February 28, 2007, 09:28:10 AM »
Thank you Brian,

The lack of a properly installed license will surely do this.

Bob
Re: Another G-Code Loading Problem
« Reply #5 on: February 28, 2007, 05:46:12 PM »
what is the     (  G91.1  )
Re: Another G-Code Loading Problem
« Reply #6 on: February 28, 2007, 05:54:14 PM »
I have no idea.  The G-Code file was created by processing a DXF drawing through LazyCam.

Bob Segrest
Re: Another G-Code Loading Problem
« Reply #7 on: February 28, 2007, 08:48:23 PM »
G91.1 will set the acrs to Inc for that one file... I did that so you would not say "My arcs are not right" if you had ABS arcs...

it will not change the settings in mach3
Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com