Hello Guest it is December 09, 2019, 04:42:10 PM

Author Topic: Stepper running rough with Mach3 at low speed  (Read 6314 times)

0 Members and 1 Guest are viewing this topic.

Stepper running rough with Mach3 at low speed
« on: October 24, 2013, 06:53:36 AM »
Hi Folks!

Im trying to set up my own built Plasma/Router Table with Mach3.

I use 6 Nm Nanotec Steppers with Nanotec SMCI36 controllers. When I run these Motors in 1/4 Step mode directly controlled by the NanoPro configuration software, which is connected to the SMCI36 controller (at RS485), the motors run very silently and equally at 10 RPM.
But when I jog the motors in Mach3 at the same speed, the motor produces noise und seems not to run so equally (but it runs..). At faster speeds, the motor seems to run ok when jogged by Mach3.

Also the max speed of the motor when controlled by Mach 3 is only 650 RPM. When I run the motor with the NanoPro configuration software, a can reach speeds up to 900 RPM without loosing stepps.


Has anyone an idea why this occurs? Is it normal that steppers controlled by Mach3 are noise and make high pitch sounds at low speeds?
Could there be a problem with an unstable clock signal ?

Im using an Pentium 4 2 GHz PC, with 1GB Ram running Windows 7. Kernel speed is 25 KHz (also tried faster..).. no change. The driver test utitly states Excellent or Stable most of the time..

Thanks a lot for any help on this problem!

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Stepper running rough with Mach3 at low speed
« Reply #1 on: October 24, 2013, 07:28:58 AM »
Few things, first it would seem that the software you are talking about will be sending signals to the drives and they will be doing the actual motion rather than looking for input signals on the step/dir pins. That will mean you will not see any effects of a bad pulse stream. Do the driver test (in Mach3 folder) and see what the graph looks like, if it is smooth then that is an indication that your computer is happy with the Mach Driver. If it has spikes then you may have issues.
Another thing it could be is that your drives require quite a wide pulse, to test that theory out choose Sherline mode (ports and pins main page) and restart then see if its better.
Hood
Re: Stepper running rough with Mach3 at low speed
« Reply #2 on: October 24, 2013, 10:51:14 AM »
It is exactly as you say. The NanoPro Software just configures the drive to do the motion.

So, it seems I have a bad pulse stream. I will try to use a function generator to input a clean steady pulse signal at the

drives input and see if the motor turns silently and clean at low speeds. Then I'll know for sure, that the reason for this

bad running at low speeds is the high jitter of the clk signal from Mach3.

What I dont understand, I disabled almost every other service on windows, disabled every graphic mode which consumes cpu

speed and this does change nothing...

When I start the driver test program, I think it looks not to bad (smooth)..  but sometimes there is a spike.. I will post a screenshot, when am back at the machine.
Is there any information for what is good? Maybe a screenshot from a pc which has proven ok?

What I'm interessted in, have you guys made similar experience with your stepper drives ? So that would mean, that I have

just to accept the way it works now.. or do I hava an issue, which has to be dealt with?

For now, I just see, that I can't get the maxi performance out of the motor/drive with Mach3 controll..


Today I set up LinuxCNC. Results in the same behavior at low speeds. Plus: I get a warning from EMC, that I have somtimes a high delay time.. Seems that there really is an issue. As it seems my chipset is using a SMI Interrupt (System Maintenace Interupt) which is known to destroy real time performance.. hmm.. but to solve that, it seems that I have to recompile some modules under linux..

The same problem should also occur on windows with Mach3...

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Stepper running rough with Mach3 at low speed
« Reply #3 on: October 24, 2013, 03:31:41 PM »
Did you try using Sherline mode?
Hood
Re: Stepper running rough with Mach3 at low speed
« Reply #4 on: October 25, 2013, 02:29:31 AM »
Hi!

Yes, I tried the Sherline Mode. No change in the behavior at low speeds  :-\


I'm setting up an other computer at this moment.. hope this will solve these problems..
Re: Stepper running rough with Mach3 at low speed
« Reply #5 on: October 26, 2013, 08:13:02 AM »
Try to set "Driving Current" lower in your stepper drivers. I think is not a computer problem.
Steps too "Hard" for soft moving mechanics.