Hello Guest it is September 27, 2020, 12:30:41 AM

Author Topic: Spindle control in Mach3- M codes do the wrong thing  (Read 3199 times)

0 Members and 1 Guest are viewing this topic.

Offline Joz

*
  •  18 18
    • View Profile
Spindle control in Mach3- M codes do the wrong thing
« on: October 01, 2013, 11:38:25 AM »
Hi, I have just set up my spindle in mach3. I must have wired it wrong or I'm misunderstanding something because when I enter a M5 command the spindle starts and when I enter a M3 it stops, which is backwards? I'm new to this as you can probably tell.
My set up is a breakout board HG08 connected to a Spindle VFD 2.2KW. I've connected two wires from the BOB relay to the DCM and FOR terminals on the VFD.
I have changed the DirLowActive settings and the StepLowAc settings in ports and pins>motor outputs through various combinations with no different results.
I have swapped the wires around that connect the relay to the VFD.
Clicking the button "Spindle CW F5" in Mach3 Program run does start and stop the spindle.
Also the spindle will run whether or not the EStop buttons are pressed or reset is pushed in Mach3, is this normal?
The VFD Manual says to set the control to PD001 "set by external terminals" which I think allows the spindle to be controlled by a relay, I have done this although I do wonder if it's a setting in the VFD rather than in Mach3 that is wrong.

Any advice gratefully received
Joz

 
« Last Edit: October 01, 2013, 11:47:54 AM by Joz »

Offline ger21

*
  • *
  •  6,285 6,285
    • View Profile
    • The CNC Woodworker
Re: Spindle control in Mach3- M codes do the wrong thing
« Reply #1 on: October 01, 2013, 11:48:12 AM »
What happens if you toggle the active low setting for the output pin that turns the spindle on/off?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Joz

*
  •  18 18
    • View Profile
Re: Spindle control in Mach3- M codes do the wrong thing
« Reply #2 on: October 02, 2013, 01:54:24 AM »
changing DirLowActive in motor outputs makes no difference

Offline Joz

*
  •  18 18
    • View Profile
Re: Spindle control in Mach3- M codes do the wrong thing
« Reply #3 on: October 02, 2013, 02:00:42 AM »
when I come out of the config settings Mach3 resets which is normal but this causes the spindle to start running.
Also, triggering any of the home switches causes the spindle to start up.  ???

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Spindle control in Mach3- M codes do the wrong thing
« Reply #4 on: October 02, 2013, 09:06:50 AM »
Sounds like you have the M3 and M5 SWITCHED as far as pins/ports are concerned.

(;-) TP

Offline ger21

*
  • *
  •  6,285 6,285
    • View Profile
    • The CNC Woodworker
Re: Spindle control in Mach3- M codes do the wrong thing
« Reply #5 on: October 02, 2013, 09:17:50 AM »
There are no ports and pins for M3 and M5. You assign a single output to M3. So it's only one pin.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline Joz

*
  •  18 18
    • View Profile
Re: Spindle control in Mach3- M codes do the wrong thing
« Reply #6 on: October 02, 2013, 09:47:27 AM »
Yep I have clicked Active Low on input signals> output #1 and it's behaving now  ::)
Steep learning curve hey
thanks
Joz