Hello Guest it is September 24, 2020, 10:46:01 AM

Author Topic: Turn and rear tool posts  (Read 1914 times)

0 Members and 1 Guest are viewing this topic.

Turn and rear tool posts
« on: September 30, 2013, 04:00:26 PM »
I'm running R3.042.033 on my lathe. It's setup with a gang tool plate. Most of the tools are setup as front post, however, I do have a cutoff tool I'd like to use as a rear post tool. Based on an old topic from 2009, using a mix of front and rear posts didn't work, but was something which was going to be fixed. Did it ever get fixed or am I SOL? (I have tested it on this version, and selecting rear post has no affect on the direction of tool travel as it should.)

If mach won't deal with it properly, what are my best options for coding it? My first thought is to just code it with negative values.

Thanks
Chris Manning
silverhandstudios.com

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Turn and rear tool posts
« Reply #1 on: September 30, 2013, 04:13:46 PM »
It will not be fixed in Mach3, it is however fixed for Mach4, or at least it is supposed to be, Brian sent me a screenshot showing front/rear toolpaths being used, see below.
Anyway you have two options, either change the code manually to negative X values or you can call a G51x-2 (or G51X-1 if using Radius mode) before the first rear tool is called then after the rear tool moves are finished you cancel with a G50.
Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Turn and rear tool posts
« Reply #2 on: September 30, 2013, 04:14:57 PM »
Forgot to add the screenshot of Mach4 using front/rear turrets.
Hood
Re: Turn and rear tool posts
« Reply #3 on: October 08, 2013, 03:32:06 PM »
Sorry, I forgot to check for replies.

Ok, in the short term I'll just use negative values, and look forward to better support in Mach4.

Thanks