Hello Guest it is October 23, 2019, 05:27:11 PM

Author Topic: help with mach 3 not running at g coded feedrate  (Read 6730 times)

0 Members and 1 Guest are viewing this topic.

help with mach 3 not running at g coded feedrate
« on: September 12, 2013, 04:19:43 PM »
this is the g code from mach 3

should it not run at 250?


it runs at like 1.93? I run past g codes and they work fine
it shows federate of 250 in mach 3 but does not run it

N0001 (Filename: circle gav.tap)
N0011 (Post processor: Mach3 plasma.scpost)
N0021 (Date: 12/09/2013)
N0031 G20 (Units: Inches)
N0041 G53 G90 G91.1 G40
N0051 F1
N0061 S500
N0071 (Part: circle gav)
N0081 (Operation: Outside Offset, LAYER1, T2: Jet tool)
N0091 M06 T2 F250.0  (Jet tool)
N0101 G00 Z0.3937
N0111 X1.9688 Y-0.2796
N0121 Z0.1181
N0131 M03
N0141 G04 P0.02
N0151 G01 Z0.0591 F3.937
N0161 Y-0.0296 F250.0
N0171 G03 X1.9687 Y-0.0296 I-0.0000 J1.9983
N0181 G01 X1.9688 Y-0.2796
N0191 M05
N0201 G00 Z0.3937
N0211 M05 M30


Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: help with mach 3 not running at g coded feedrate
« Reply #1 on: September 12, 2013, 08:17:17 PM »
IF you look on line # N0151 you will see that the GCODE tells mach3 to slow down to F3.937.

That would be 3.937 INCHES per min, SLOW.

Looks like you have the wrong feedrate set in sheetcam for THAT tool#.

(;-) TP
Re: help with mach 3 not running at g coded feedrate
« Reply #2 on: September 13, 2013, 08:24:43 AM »
the next line goes back to 250
I'd seen this happen to from time to time with some of my runs, not sure why mach was doing it so I had to change my post to output feed rates on all g1 moves. Just thought it was another quirk with mach. Very exciting when it took off at rapid rate during what should have been a feed move. For awhile I had the rapid override set and turned on to a feed rate that would save me from cussing.

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: help with mach 3 not running at g coded feedrate
« Reply #3 on: September 13, 2013, 10:08:02 AM »
YEP running blind eyed today. What version of Mach3 are you running??

(;-) TP
Re: help with mach 3 not running at g coded feedrate
« Reply #4 on: September 13, 2013, 01:33:36 PM »
3.043.062
could step back a couple, but the Smooth Stepper E works well with it and I hate fighting that battle again, lol might just have to.
Also the same version running with the Dynomotion Kflop/Kanalog, so that might be the issue. Does it on both machines.

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: help with mach 3 not running at g coded feedrate
« Reply #5 on: September 13, 2013, 01:54:51 PM »
OK I just ran into that as well do a sub routine RUNNING with the LPT driver. V.067

ONLY  on G1 it was ok and with G2 it ran at rapid speed regardless of the F###

(;-) TP

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: help with mach 3 not running at g coded feedrate
« Reply #6 on: September 13, 2013, 02:03:46 PM »
Just a s a note YOUR code runs fine here.

(;-) TP
Mach 3 Display window not showing the correct size of project
« Reply #7 on: April 02, 2018, 09:17:30 PM »
Can someone help me? I'm retired and bought a Cheap Chinese 3040 CNC router. It was running fine I did two nice name plates with it. Don't know what happen but the G-code fonts got small and the display window does not show the project in the correct size.  Checked all my pin & port setting nothing has changed. So I uninstalled Mach 3 and reloaded the program
Same thing is going on. In settings I run inches the X,Y,Z all move 1". Load the G code and the same thing. Project is so small you can not see it on the display. Under last wizard box a yellow box says Abnormal condition I J mode absolute. So I downloaded Mack 3 trial version again and installed it and everything is the same. HELP

Offline Tweakie.CNC

*
  • *
  •  7,958 7,958
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: help with mach 3 not running at g coded feedrate
« Reply #8 on: April 03, 2018, 05:17:54 AM »
Hi Farv,

Welcome.

If your machine is set-up in Inch units and the Gcode file you are using has been compiled in Millimetre units then everything will be small unless...

Use Notepad to edit your Gcode file to add G21 (on a new line) at the start of the Gcode listing. This tells Mach3 that the file is in mm units and it will then scale the axis movements to match your machine units setup (hopefully).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: help with mach 3 not running at g coded feedrate
« Reply #9 on: April 03, 2018, 11:16:34 PM »
Hi Tweakie.
Thank you so much for your reply. My projects are in inches and this is the way I have Mach 3 set up. I did try entering G21 just to make sure. Nothing has change. As soon as I can figure out how to do it I will upload a photo of my screen. In my diagnostic screen when I push the up arrow key I do not see any LED's light up, only when I set the E stop. Also in Port 1 pins current state I have 5 LED's in the upper row showing green.