Hello Guest it is November 12, 2019, 05:23:11 AM

Author Topic: Using the B axis for my 4th axis?  (Read 2069 times)

0 Members and 1 Guest are viewing this topic.

Offline cdf

*
  •  4 4
    • View Profile
Using the B axis for my 4th axis?
« on: September 03, 2013, 09:12:41 AM »
I have a 4 axis cnc router running on mach3. It uses 2 steppers on the Y axis. I have been using it as a 3 axis machine with success. I built the electronics box with a g540 running the A axis slaved to the Y axis. I also have installed a Chinese breakout board with a g251x in my electronics box with the intention of running the 4th axis off it. This works fine as far as being able to manually jog the 4th axis. The first problem came when I realized that the gcode from rhinocam wanted to control the 4th axis with the A axis in mach3. I then switched things around to run the 4th axis on the A axis of the g540 and slaved the B axis on the Chinese breakout board to the Y axis. In this configuration I can't get the Chinese board to play nice being slaved to the G540.

Is there a way to run the 4th axis from the B axis so I can leave the four X,Y, and Z stepper motors on the g540 since they all play nice that way?

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Using the B axis for my 4th axis?
« Reply #1 on: September 03, 2013, 10:30:55 AM »
All you need to do is change the pin#'s in Mach3 so that your original A axis is assigned to the B axis, and in Config>Slaving, slave the B axis to the Y. Yopu shouldn't have had to change any wiring at all.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline cdf

*
  •  4 4
    • View Profile
Re: Using the B axis for my 4th axis?
« Reply #2 on: September 03, 2013, 10:42:55 AM »
Thanks for the reply. I spent all night last night trying to figure out a solution. As soon as I posted this thread I came up with a solution. Sometimes I feel like posting a question helps me think about the problem from a new light. I figured out that in rhinocam I can change the 4th axis to post as b axis in the preferences.

So now if anyone searches this problem and finds this thread there is two solutions to the issue!