Hello Guest it is July 06, 2020, 01:01:10 AM

Author Topic: Random external stops and FIFO empty error- already tried debounce settings  (Read 2764 times)

0 Members and 1 Guest are viewing this topic.

Helping a friend debug his waterjet running Mach3. We get random external e stop requested messages resulting in the machine shutting down. I also see FIFO empty right before it crashes. Have gone around the control console, waterjet table and pump/intensifier and tightened all wires and connections I can find that are loose. Tapped the PLC on the pump/intensifier and find the error log set to on but nothing is written to it. It is a commercial turnkey package that was installed and preconfigured by the manufacturer. Manufacturer support has been less than impressive.

Tried the following in Mach3:
Set debounce from 3 to 2000 with no change.
Set the look ahead to 10 from 100 thinking it might be looking to far forward in the buffer.

Thanks in advance for any suggestions.

Offline BR549

*
  •  6,932 6,932
    • View Profile
Re: Random external stops and FIFO empty error- already tried debounce settings
« Reply #1 on: September 02, 2013, 10:04:44 PM »
Look under gen config and see if the watchdog timer is ON. If it is turn it off then save then shutdown Mach3 and restart.

Just a thought, (;-) TP

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Random external stops and FIFO empty error- already tried debounce settings
« Reply #2 on: September 03, 2013, 03:36:59 AM »
Are you using the parallel port or an external controller?
Hood
Re: Random external stops and FIFO empty error- already tried debounce settings
« Reply #3 on: September 03, 2013, 06:45:37 AM »
Will stop into the shop on the way to work and take a look at the watchdog setting. Will turn it off and have him run a long project to test. We cant get more than about 1.5 hours out of it. Usually its less than 30 minutes. Not bad for $100K ;)


Everything in the control box is plugged into a board that says Hicon on it. So external?

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Random external stops and FIFO empty error- already tried debounce settings
« Reply #4 on: September 03, 2013, 06:48:11 AM »
Ok so it is external so debounce will not have any influence on it. You may find some settings for filtering in the plugin, never used a Hicon so cant help too much with that. There is a section of the forum for it however so may be worth asking there.
Hood
Re: Random external stops and FIFO empty error- already tried debounce settings
« Reply #5 on: September 03, 2013, 07:41:48 PM »
Watch dog off gave the longest run the machine has had in ages. He plans to do a 3 hour plus run in the morning. If this doesn't pan out then I will learn more about the Hicon side and figure out what their version of debounce is and find out if the FIFO error is really an issue. Thanks for the help so far.