Hello Guest it is July 16, 2019, 02:53:15 PM

Author Topic: Need some help with the Servo Configurator 3 software and DG45 driver issue.  (Read 2540 times)

0 Members and 1 Guest are viewing this topic.

Offline poppabear

*
  • *
  •  2,231 2,231
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
   I am having GREAT trouble with the DG45 servo configuration software.  It will NOT connect to the drive(s), At all…..  I have installed the Servo configurator 3 software, per the instructions, to include the FTDI driver install (for the programming stick).
   When I do a scan it will NOT see any drive(s)…….   Also, both the Red and Green LEDs on all three drives are ON, (solid color no blinking). When you look in the Servo Cfg user manual, those LED states are NOT covered, so I have NO clue as to what they mean.
   Is it Possible I have a “Bad” programming stick??  I have tried the servo Coagulator 3 on a Vista (64bit), AND on a XP Pro machine. It will NOT connect from either computer
   I have tried uninstalling/installing the Servo config software (and drives), multiple times all to no effect. I have read the DG45 manual, and Servo Config manual, so, I am at a loose to understand why it cannot even see the drives. It DOES see the FTDI module in the Programming stick, and when I plug it in, it installs the driver for the programming stick, but when I try to connect, it tells me the drive(s) (all three do the same thing), That the Drives are NOT responding and they time out.
    I am running an ESS through a C32 board, and using the C34DG4S translator cables.
If anyone has run into a similar problem, or you have a solution, by all means PLEASE contact me!

Thank you, Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/

Offline derek

*
  •  201 201
    • View Profile
Hi Scott
I had 2 issues with my setup.
The first one was bad solder joints on the 4 pins that connect it to the drive.

The other was tougher and I never really solved it. Although I really didn't try too hard.  I couldn't get it to recognize the drive through the XP machine I have on the computer. I ended up rolling over my shop XP machine that I use for testing and such and used it to tune the drives.

I know this doesn't help much but it's all I got :)

On the plus side the drives and the UC300 motion card are awesome.

Derek

Offline poppabear

*
  • *
  •  2,231 2,231
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Ok, I got some answers from Balaz, of CNCdrive, and Arturo of CNC4PC must say, VERY good customer support.

The problem, is an "Undocumented one".
I was given a list of things and steps to try, from both Balaz and Aurturo.
Here is the email, for those of you who may be in a similar boat.

I will try these things and let you know my findings.

Quote
Hey Scott,

Thanks for your email, how you doing.

The red + green LED solid on state is the booting sequence of the drives. These LEDs goes on when the drive is powered up and is booting up and this is the LEDs states always when you switching the power to the drives on, this state is for about 4-5 seconds in the running beginning and after that the drives should start running or go to a fault, depends on your connections  etc.
        If the drive continiously showing the red + green LEDs on states always can be if they not leaving the booting sequence which can be if you holding the drive's reset pin always active (low), so the drives as soon as finishing hte booting they reset and going back to booting again, so you will always see the booting states of the LEDs.
     Also this LEDs states remains if the firmware of the drive is broken, in this case the drive not going out of the booting, if there is a CRC error of the firmware.
And there can be a 3rd case too when the drive always showing red + green LED activity, if the microcontroller stay in power on reset, this happens if the Voltage for the MCU is too low, between about 3-4Volts and not reaching the 4.2Volts level when the drive could safely start the operation.
       What I'm advicing to do for first:
Try to remove all drives from the system and pick a patch cable and connect only the 12Volts to the drive's Main RJ45 connector's 7. and 8. pins, these are the "digital power supply input pin" wires.
     I mean do not connect anything else yet to the drive and only connect one drive to the 12Volts. See if it powers up. It should show first both LEDs on for 4-5 seconds (booting) and after it should show rapid red LED blinking which indicates an unconnected encoder error.      If this works then try to connect the encoder to the drive. and power up again and your drive should again show red + green LED both on and after 4-5seconds it should start blinking the green LED only which means normal running state. (if the encoder is hooked up correctly). After this you can connect the programming stick and run the Servoconfig3 and connect to the drive with the software etc.
    Please also note that the drives communicating via the USB only if they are out off all kind of faults, in case they entering any faults they stopping the communication via the USB.
     So, to connect the drive successfully to the Servoconfig3 software you must have the drive in normal running state. (red LED off and green LED blinking)
     And one more thing is to do not "hotplug" the programming stick to the drive, physically only connect the progstick to the drive when the drive's digital part is unpowered.
       Otherwise if you plugging the stick when the drive is already running can cause a "communication packet error" when the drive will reset and may remain in booting until you reseting it via the reset pin or toggling the digital PSU switch off/on.
So, first please try with the minimals connected, not everything wired up and do things step by step to finally have a working system with everything wired up. :)

Best Regards,    Balazs

Quote
Scott/Balazs,
    Yes, the problem with the LEDs is a power problem.  I have already one more case like this.  I have not been able to reproduce the problem here, but the other case was fixed by powering this with +12vdc.  I may have more info on this very soon.  In any case, I can send a C34DG so you can power this with +12vdc to get you running.

Arturo
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/