Hello Guest it is May 08, 2021, 05:40:53 AM

Author Topic: How to manually set Current Position, Machine Coord, and Work Offset to zero.  (Read 21250 times)

0 Members and 1 Guest are viewing this topic.

I would like to manually set Current Position, Machine Coord, and Work Offset to zero and have found no way to do so.

My machine is a Bridgeport Series II running Mach3 Ver. R3.042.038 on a good XP system.  The Bridgeport has built in x and y axis position displays so all I have to do is startup the machine and jog the bed to the correct x and y positions, then press RefAllHome to zero Current Position to that location. 

Or so one would think.  When I press RefAllHome I notice my x axis moves a slight bit resulting in the Current Position changing slightly.  When I move the bed so Current Position is back to zero I find that either or both the Machine Coord and Work Offset isn't at zero.  I want them all at zero.  I want to simply move the bed to any location and set that location to zero for all.

The settings Copy G54 from G59.253 is not checked, Persistent Offsets and Persistent DRO's is checked.
G54 is set to all zero's.

This should be easy.  It's not.  I'm totally stumped.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
If you press RefAll and your machine has no Home switches set up then Machine COORDs will be set zero (or the value you have in Home Off) at the position you are presently at.
If your Work Offset is not also zero (ie the DROs do not read zero in Mach) then press the Zero at the side of each DRO and that will set them Zero.

You mention the axis moves slightly when you press RefAll, are you meaning it physically moves or just the DRO? If the former then it should not do that and would seem to be an issue with your config, so attach your xml if that is the case.


Hood
Thank you very much for your help.  I hope this reply gets to you.  My first reply timed out on this end so I am trying again.

You are correct that my machine has no home switches on the x and y axis, only on the z.

I have attached the xml file because when I start up Mach3 the x axis moves slightly.  This happens during the time Mach3 is loading and not at any other time.
Then - I press the reset button to enable Mach3 control and jog the axis back to the right place.
Then - I press the RefAll to set the coordinates to zero.

This all works just fine except now the Machine Coord, and Work Offset settings are off by the amount I moved the x axis to return to my intended zero.

So as a recap, the x axis bumps a step or two when Mach3 is loading.
Returning the x axis to where I want it to be and pressing RefAll sets Current Position to all zeros, but now the Machine Coord, and/or Work Offset is off by the exact distance I moved the x axis.

Wow.
I would have thought there would be some way of forcing all the settings to zero by just moving the axis where you want them to be and pressing a button to reset Current Position, Machine Coord, and Work Offset to zero at that location.
Apparently not, which I find astounding.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
When you start Mach there is a good chance your axes will move slightly, that is why you should really use an accurate method of homing the machine if you are wishing the position to be accurate from session to session.

Moving the X to where you want zero to be and pressing RefAll should set both machine coords and work coords to zero, assuming you have no work offset, which in the xml you attached is true. I have tried it with your xml and it does do exactly as it should.


Now to your next post, you can quite easily add a button to the screen or even modify the RefAll button to do a RefAll then Zero all axes work offsets. However doing it the standard way with accurate home switches would be the best all round way to do things I would think, it is the only way you will always be sure that you are exactly the same position each time you start Mach and home.
 Altering the RefAll script will assure that machine coords and offset coords will be zero when you press the button but that will not ensure that your machine is in the same position it was yesterday when you did that, unless you have a fool proof way of knowing you are exactly in the same position when you press the refall every single time.

Hood
Thank you for your timely and sage advice. 

I, by good fortune, have a highly accurate method of homing the machine.  Built into the mill is a precisely accurate mechanical position readout, allowing me to position the bed to exactly the same position repeatedly.  It is foolproof.

Therein lies my problem.  When I exit Mach3 I make sure the bed is positioned precisely where I want it.  When I start Mach3 the bed moves slightly.  So I reposition the bed to where I want it before pressing ResAll.  Pressing ResAll jogs the bed to precisely where it moved to when Mach3 started and sets Current Position, Machine Coord, and Work Offset to zero at that location, not at the location I moved it to.  When I return the bed to the location it was in when I pressed ResAll, the Machine Coord and/or Work Offset is changed by the amount the bed originally moved.

I have a feeling I am going to have to make a video to show what is going on.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Pressing RefAll should NOT move the X or Y axis at all as you do not have Home switches set for the X or Y. The only axiis that should move when you press RefAll is the Z axis.
If your axes are moving (other than Z) then it would seem you have possibly got custom script in the RefAll button.

Hood
« Last Edit: August 18, 2013, 07:36:12 AM by Hood »
Thank you again for your help yesterday, and I think I have narrowed down where the problem is.

It's the machine coord setting.  When I start Mach3 the machine coord setting isn't zero.  It's -.0005 every time no matter what I do.  

If I have AutoZero enabled for the axis, when I RefAll the axis will move till machine coord is at zero and then clear the Current Position.  Problem is, the axis is no longer where I want it to be.  I don't want that.  I have already set the axis to where I want it before I start Mach3.  If I jog the axis back to where I want it to be and then press RefAll again, the Machine Coord and Work Offset is not zero.

If I disable the AutoZero in Homing & Limits, then when I RefAll the axis doesn't move but the Current Position and Machine Position isn't set to zero either.  Current Position and Machine Position stays at -.0005.

What I need is a macro or some-such to force Current Position, Machine Position, and Work Offset to zero.

Any suggestions?  

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
I will say again, your Axes should NOT move when pressing RefAll if you do not have Home switches configured for the axes.
AutoZero simply tells Mach to set Zero (or Home Off value) to the machine Coords DROs when you reference the machine.

You seem to be saying that when you press RefAll not only does the Z axis physically move but the X and Y do as well. Z moving is correct as you have a Home switch designated in Ports and Pins for that but X and Y should not physically move.

Your xml shows you have the macropump enabled and also you are using a Vista pendant, could these be your issue?
Are you pressing RefAll on the screen or is it a function of the Pendant? If screen can you tell me what the script is in the button please.
Can you also tell me what is in the macropump, maybe zip and attach it.

hood

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
One last thing, your xml seems to suggest you are using the parallel port (no device listed for controller) is that the case?
Just that if that is the case then there are no ports and pins chosen for the axes and that can not be correct if using the parallel port.
 I am wondering if you are  using an external controller or possibly have attached the wrong xml?
Hood