Hello Guest it is May 20, 2019, 07:41:58 PM

Author Topic: Problems with mach3 setup  (Read 1961 times)

0 Members and 1 Guest are viewing this topic.

Problems with mach3 setup
« on: August 17, 2013, 06:02:38 AM »
I have just purchased mach3 and installed it to a freshly installed XP computer. When I load a toolpath the toolpath viewer shows purple rings and when I run the gcode my mill starts milling my toolpath but also the purple rings. I have added a screenshot of the problem. Can somebody help me?

Offline Tweakie.CNC

*
  • *
  •  7,764 7,764
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Problems with mach3 setup
« Reply #1 on: August 17, 2013, 06:36:03 AM »
Within Mach3 - click, Config / General Config then change your IJ Mode.

It all depends on how your CAD / CAM software generates the arcs so to be sure you should always include  G90.1 or G91.1 (as appropriate) at the start of your GCode program files (perhaps modify your post processor to do it for you automatically ?).

Tweakie.
« Last Edit: August 17, 2013, 06:38:07 AM by Tweakie.CNC »
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Problems with mach3 setup
« Reply #2 on: August 17, 2013, 08:08:03 AM »
I seemed to have solved the problem. During the Mach3 installation process I've created a new profile for my milling machine. I've now tried using the Mach3Mill default profile and the problem is solved I can now see and mill my toolpath without the strange spiral. The error is created by the generation of a new milling profile. Did anyone run into that same problem?

 

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Problems with mach3 setup
« Reply #3 on: August 18, 2013, 04:27:06 AM »
It has nothing to do with making a new xml, well it does in a way but it is not the xml that is the issue.
The issue is as Tweakie says, the IJ mode set as default in your xml.
Your code has the IJ mode one way and Mach is set default the other way. That is why in good code there will be a G90.1 or G91.1 at the start to tell Mach which mode to use.
Hood