Hello Guest it is November 15, 2019, 06:39:49 PM

Author Topic: mach3 lathe changing its own offsets  (Read 1646 times)

0 Members and 1 Guest are viewing this topic.

Offline fast89

*
  •  137 137
    • View Profile
mach3 lathe changing its own offsets
« on: August 15, 2013, 01:02:19 PM »
Ok, i set up to run some parts this morning, got about 10 done then a part came out of the collet. I thought it might have been random, loaded another part and watched it. The drill was off center .600". Well thats odd. Checked the work offsets and sure enough it was not the right distance from home. It happens on every run of the program, it rights something into g55 which i am not using and changes g54. I thought the program had some sort of corruption so i made an entirely new program. Nope not it. I deleted the m6start macro and put my backup copy in there. Nope not it. Anyone ever had this happen or seen it. I'm stumped. I haven't changed my screen, or pokeys setup.

Offline fast89

*
  •  137 137
    • View Profile
Re: mach3 lathe changing its own offsets
« Reply #1 on: August 15, 2013, 01:50:50 PM »
OK, it is the tool change rewriting the offsets. Haven't modified that macro so I'm not sure what happened here. I guess i will rewrite it and see if that helps. Seems to only be tool 2 and 8.

Offline fast89

*
  •  137 137
    • View Profile
Re: mach3 lathe changing its own offsets
« Reply #2 on: August 15, 2013, 02:49:25 PM »
Figured it out. Somehow tool 8 got set to rear toolpost. Man did that make a mess of things. Got it sorted out though and it's back to making parts.