Hello Guest it is July 06, 2020, 07:38:46 AM

Author Topic: Output  (Read 2555 times)

0 Members and 1 Guest are viewing this topic.

Offline mvoros

*
  •  141 141
    • View Profile
Output
« on: August 12, 2013, 10:47:26 AM »
Could anyone tell me why Output 6 is flashing constantly.
Mike

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Output
« Reply #1 on: August 12, 2013, 01:36:13 PM »
Would really need to see your xml to see why but could be a brain or the macropump or even just something you have configured to Output 6.
Hood

Offline mvoros

*
  •  141 141
    • View Profile
Re: Output
« Reply #2 on: August 12, 2013, 02:35:53 PM »
My post doesn't go thru, what gives?

Offline mvoros

*
  •  141 141
    • View Profile
Re: Output
« Reply #3 on: August 13, 2013, 07:02:15 AM »
Hood,
I'm going to try again. It seems that only you pick up on my troubles, and I thank you for that. I don't understand what's happening. I was running the machine on Saturday, and today nothing seems to work. I get odd messages from Mach never seen before, the MDI doesn't work, fixture offsets are not saved. It seems like Mach has gone berserk on me. I'm thinking of installing an earlier version, R3.043.022. Would this one work with ESS? Regarding the Output 6 flashing on the diagnostic's page, I disabled the Brain but that doesn't stop it. I can't see anything set for it on the Ports/Pins Outputs page. Could this be what starts the spindle? Please help me.
Mike

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Output
« Reply #4 on: August 13, 2013, 07:25:26 AM »
Ok first thing I see is you have the Z++ limit set to the same port and pin as ZHome, however you have the Z Home as Acitve Low but the Z++ as active High, think likely the Z++ should also be active Low.
Hood

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Output
« Reply #5 on: August 13, 2013, 07:27:39 AM »
You also have the kernel set to 100KHz, unless you have a very fast and stable computer you will have problems with that. You should ideally just set the kernel to what you need for your motor tuning. In your case that is 45KHz

Hood

Offline mvoros

*
  •  141 141
    • View Profile
Re: Witch version of Mach
« Reply #6 on: August 13, 2013, 11:37:20 AM »
Hood,
I corrected the above. I still like to know if R3.043.022 is a stabler version than .066 ver. I got an email from Arturo about the spindle starting when Mach is closed. His suggestion is, to get a charge pump gizmo from him, and that may solve this issue. As for the Output 6 flashing, you were right, it is the MPG's Brain being enabled that make it flash. I need that MPG to work, as well the eStop is wired to it, so to hell with the flashing, I say. I'm starting to rethink this retrofit with the CNC4PC stuff. Leaning towards the PMDX components.
Mike