Hello Guest it is October 17, 2019, 10:31:38 PM

Author Topic: Diagnostic Page  (Read 1969 times)

0 Members and 1 Guest are viewing this topic.

Offline mvoros

*
  •  141 141
    • View Profile
Diagnostic Page
« on: July 16, 2013, 03:13:54 PM »
Hi,
Can anybody tell me why output 6 is flashing on the diagnostic page?
Mike

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Diagnostic Page
« Reply #1 on: July 16, 2013, 03:37:14 PM »
You must have something turning it on, maybe a macro or macropump or a Brain or maybe even a plugin.
Hood

Offline mvoros

*
  •  141 141
    • View Profile
Re: Diagnostic Page
« Reply #2 on: July 16, 2013, 04:49:02 PM »
Thank you Hood. I've been struggling with CNC4PC MPG2 for weeks now. Today I decided to remove it from my system, because we (Arturo and me) couldn’t get the step switch to work on it. Guess what, I deleted the mpg's brain, and output #6 stopped flashing. so much for that problem. There is one other thing you could help me with please. I retrofitted the router with Ethernet Smooth stepper. It works really good, I run hours of hours of long programs from the past without a hitch. The problem I have is when I exit Mach, the spindle starts up. I can work around it, by shutting the control down first, than Mach. I'm using CNC4PC's C41 spindle control board to control the VFD. I can program different speeds, the M5 command works by stopping the spindle. Having used Mach3 for the past 6 years, I never encountered such problem before.
Mike
« Last Edit: July 16, 2013, 04:50:50 PM by mvoros »

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Diagnostic Page
« Reply #3 on: July 17, 2013, 01:46:28 AM »
Thats not good, does your spindle controller not use a relay to tell the VFD to go CW or CCW?
Hood

Offline mvoros

*
  •  141 141
    • View Profile
Re: Diagnostic Page
« Reply #4 on: July 17, 2013, 07:31:58 AM »
Yes it does. The VFD I have is a very simple one, it has only a FWD, no Rev. I think the relay works ok, because the led goes off when I stop the spindle. I took this issue up with Arturo and Greg and they're talking about a pulldown resistor, but do not say how to or where to put it. Attached is a jpg of how the VFD is wired now.
Mike

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Diagnostic Page
« Reply #5 on: July 17, 2013, 07:42:39 AM »
Ok it sounds like they think it is floating when off, best idea is to email Greg and ask his advice on size and location of resistor. Greg is a great guy and will definitely give you sound advice with anything regarding his SS, may just take a day or two as I think his email load is pretty high.

Hood