Hello Guest it is November 16, 2019, 04:20:05 PM

Author Topic: Gecho 540 and vfd spindle set up.  (Read 3333 times)

0 Members and 1 Guest are viewing this topic.

Gecho 540 and vfd spindle set up.
« on: July 09, 2013, 11:33:24 PM »
Could any body help me .

How do I set up Mach 3 spindle settings  for a Gecko 540 and a VFD.  Particularly PWM Base Frequency  and  Mnimum PWM, if this is the correct motor controle to use?

Thank you.

The help here is amazing.

Buchanan

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Gecho 540 and vfd spindle set up.
« Reply #1 on: July 10, 2013, 07:28:58 AM »
Just downloaded the sample xml from Geckos site and this is what it shows for PWM setup.
Hood
Re: Gecho 540 and vfd spindle set up.
« Reply #2 on: July 10, 2013, 04:18:45 PM »
Hello Hood.

Thank you.  I appreciat that.
I find it a little bewildering to know where to start to look.

Regards
Buchanan

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Gecho 540 and vfd spindle set up.
« Reply #3 on: July 10, 2013, 04:35:09 PM »
So is it working ok now? You may also have to set up spindle pulleys to suit your setup.
Hood
Re: Gecho 540 and vfd spindle set up.
« Reply #4 on: July 15, 2013, 07:47:52 PM »
Hello Hood

Yes It is working now but only on and off. I cannot set the speed yet.
I had an incomplete manual for the VFD and needed to change the default settings to external control. i think there is another setting for speed somewhere but i must still find it.
Yesterday my steppers all stopped working and now have the jitters,they twich backwards and fowards one step but wont turn, so i am back in the woods, lost.

Thanks again.

Buchanan

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Gecho 540 and vfd spindle set up.
« Reply #5 on: July 16, 2013, 02:07:29 PM »
Steppers twitching sounds like you have the step and direction pins round the wrong way.
Hood
Re: Gecho 540 and vfd spindle set up.
« Reply #6 on: July 16, 2013, 06:16:00 PM »
Hello Hood.

I have checked my ports and pins im Mach 3 and the are pin 2 x step pin 3 x direction pin 4 y step and so on and all seem correct so I went back to first principals and checked my wiring from my g 540 plugs to the motors. We had added an extra set of plugs to go through the machine cabinet wall on the machine and my father had muddled up the wiring sequence so all is well again. For once it was no me that had made the mistake. Thank you for your advice. We are ready to connect every thing onto the mill next so hope to cut metal this weekend if I do not make any more stupid blunders.
Thank you for your patience with a CNC Newbie.

Regards

Buchanan

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Gecho 540 and vfd spindle set up.
« Reply #7 on: July 17, 2013, 01:47:00 AM »
We have all been there at one time or another :)

Hood
Re: Gecho 540 and vfd spindle set up.
« Reply #8 on: July 17, 2013, 03:32:24 AM »
I discovered where the wiring error came in. On further investigation by my Father who does not like to make mistakes , we discovered thet out of the five male and female connectors we bought, the males terminals were all numbered the same but two of the five female connectors had terminals numbered differently the the other  three.  How does this happen.

Buchanan

Offline budman68

*
  • *
  •  2,360 2,360
    • View Profile
Re: Gecho 540 and vfd spindle set up.
« Reply #9 on: July 17, 2013, 05:13:00 AM »
It happens by humans being human and making mistakes.

Why do you think your father doesn't like making mistakes?  ;)

Glad you caught it!  :)
Dave
----------------------------------------------------------------------
Just because I'm a Global Moderator, don't assume that I know anything !

Dave->    ;)