Hello Guest it is August 18, 2019, 10:04:25 PM

Author Topic: Emergency stop erroneously activates  (Read 2304 times)

0 Members and 1 Guest are viewing this topic.

Emergency stop erroneously activates
« on: June 22, 2013, 10:30:17 PM »
I have been having a problem lately with the gcode program stopping mid program and acting as if I hit the emergency stop switch on my cnc controller.  The plastic that I have been machining lately causes a lot of dust, so I though maybe the physical switch was just getting dusty and losing contact.  So, for the sake of trouble shooting, I turned off the external stop switch in the configurations for MACH 3.  The program still stops periodically mid program and activates the EXTERNAL EMERGENCY STOP ACTIVATED.  So, how can this be if I have deactivated the input for the external stop button? Any ideas?

Offline Tweakie.CNC

*
  • *
  •  7,882 7,882
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Emergency stop erroneously activates
« Reply #1 on: June 23, 2013, 02:16:10 AM »
The first thing I would suspect is the WatchDog timer - it is of debatable use - Config /General Config – uncheck the ‘Use WatchDogs’ box.

If that does not solve the issue then the next thing I would do is fit  0.1uF miniature ceramic capacitors - connected between each used switch input and GND at the breakout board.

Tweakie. 
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Emergency stop erroneously activates
« Reply #2 on: June 23, 2013, 04:31:37 AM »
Hi, I had the same problem in the depths of winter down in my workshop, it was damp and cold which didn't help however here is a guide I wrote for myself if it happens again. All this started after a Mach upgrade which we all like to blame but red below and you might find an answer.

Finding solutions to 5v control faults.
A sort of diagnostic fault tree.
Don't assume MACH program is at fault (I firstly blamed the upgrade)
For example I have seen lots of users including me with limit switches or E stop being activated mysteriously, so before blaming Mach and going on Mach forum with a new topic follow this simple check list

Your machine stops for no apparent reason with the Status Box showing Limit switch activated, E stop activated or other unknown error message.

Investigate the following

Are you working in a cold shed or workshop and decided to put a heater in, I did and the condensation was massive. (not good news for 5v control systems and computer mother boards).

Firstly look at the Diagnostic page of Mach to see if any input/output signals have been activated then investigate offending switch or fault. If nothing shows up there could be lots of reasons for your program stopping

If no errors seen on the diagnostic page then you have an external influence causing the problem especially if you have 5v control circuits

First physically check for
Loose BOB cable connections?
Loose wire connections on your machine?
Damaged switches or wires to control circuits?
Damp, swarf or oil on connections and switches?
Checked you earth connections, tighten if needed
Are any 5v signal wire near any power wires or transformers if yes move them?
all OK then
Is your computer performing correctly, check the driver with the driver check file in your Mach folders for any spikes in the signal (see tutorial videos)
Check you computer connections and look for loose or bad connections
Have you changed anything or switched on nearby equipment (vacuum cleaner) that may cause electronic noise
Faulty florescent lighting nearby
Addition equipment nearby causing electronic noise
 all OK then
Its time to try a few changes in Mach (note your setting before changing)
Test the signal with Mach driver test and look for spikes in the signal
Change the de-bounce figure and check to see if the fault have been corrected
Un-tick the “use Watch Dog”  box in the general setting page then check to see if the fault had been corrected. If not reinstall original settings

Now you have a problem, mine was solved by noticing a overheating capacitor on the spindle drive card, giving out electrical noise so replaced it, with the help from Hood I repaired it, now all is fine
(FINGERS CROSSED).

Hope this helps

Jim

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Emergency stop erroneously activates
« Reply #3 on: June 23, 2013, 07:01:17 AM »
I turned off the external stop switch in the configurations for MACH 3.  The program still stops periodically mid program and activates the EXTERNAL EMERGENCY STOP ACTIVATED.  So, how can this be if I have deactivated the input for the external stop button? Any ideas?

Because if you mean you unticked EStop "Enabled" in ports and pins, then Mach won't let you do this. Go back in and look - you'll find it's ticked again. i.e. you can't disable the EStop input.