Hello Guest it is May 26, 2019, 07:46:38 PM

Author Topic: Motor Tuning cofiguration won't show up when clicked...  (Read 4466 times)

0 Members and 1 Guest are viewing this topic.

Motor Tuning cofiguration won't show up when clicked...
« on: June 21, 2013, 02:18:37 PM »
When I click Motor tuning it does not show up... All other configurations show up....
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #1 on: June 21, 2013, 03:05:19 PM »
Not to worry,,,  I had not loaded the parallel port driver...  All ok now.. I hope..
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #2 on: March 14, 2014, 04:09:23 AM »
Hi
I am having the same problem now. I have just got a Leafboy77 USB motion controller, and since I have added the plugin for it, the motor tuning window will not open.
Does any one have any ideas?
Cheers
Matt

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #3 on: March 14, 2014, 08:46:37 AM »
Matt,

Assuming you have put the UsbMove.dll in the plugings folder then on Mach3 restart - select the Xulifeng motion controller then you should be OK.

(full instructions are contained in the manual which can be downloaded from here http://leafboy77.com/index.php/en/articles/16-mach3/usb-motion/card-akz250/1-mach3-usb-motion-card-akz250)

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #4 on: March 17, 2014, 09:01:51 AM »
Hi Tweakie
Thanks for the link, but I had downloaded and gone thru all of that before I even plugged the controller in :) I should have looked a little longer thru the forum, as it seems to be quite an ongoing thing. I reloaded (seemed to be the most common cure) with the latest version of mach3 and tried it again and all is good.
I now have it wired into my mill and running. Had a bit of trouble with the drives and ground voltage differences, damn these cheap switch-mode power supply's, but a bit of messing around with pull up resistors and whallah, motion :)
Spindle is next. Have you.. or anyone else, had to send a dedicated STOP signal for the spindle? The VFD I am running uses latched input's, so I can trigger FOR and REV with M3/M4, but I can't stop it. When I enter M5 the output PWM stops, but the drive still runs at the min freq, about 500rpm. Is the somewhere in the Ports&Pins or spindle config to set an output for M5?
Cheers
Matt
PS sorry if i am going off topic here

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #5 on: March 17, 2014, 09:37:22 AM »
Hi Matt,

I am pleased you got the Leafboy sorted.

I can't offer any advice for your VFD / Spindle problem - perhaps someone else who has had experience of this type of setup will chime in.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #6 on: March 17, 2014, 09:41:06 AM »
Hi Matt  :)

Sound's like you have the command parameters in the drive set incorrectly.
Your fwd/rev relays should just select the dir., not turn the drive on. The PWM present from Mach should command all movement.
Which drive is it ?

Russ

Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #7 on: March 17, 2014, 10:59:29 AM »
Hi Guys
I am running a Chinese VFD and spindle, with the outputs from the Leafboy going directly to the VFD.
It is a Hyuang breed of Chinese evil.
The digital inputs seem to work the same way as the onboard controls. If you push the dir button it simply toggles from for to rev. It does give the option to set a separate input for forward and reverse, running and stop, but all of these inputs run in the same way. Once you push a button, it stays active until you push another button, ergo the separate start and stop commands required. I can get everything else to work, and am currently using the stop button on the VFD to shut it down. Unfortunately this then requires the VFD to be switched off and on to work again.

This drive does apparently support RS485 comms... in a Chinese way. I have had a brief read about this on the forum, maybe it is a better way to go?

Any thoughts?
Cheers
Matt

Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #8 on: March 17, 2014, 11:34:32 AM »
No experience with the cheaper chineeze stuff.
Do you have the manual with all of the settable parameters ? I/O points and descriptions ?

Never used a Leafboy either.

I have seen a Lawnboy Leafblower though.  :)
Russ
 ;D
Re: Motor Tuning cofiguration won't show up when clicked...
« Reply #9 on: March 17, 2014, 03:09:18 PM »
Hi Russ
Yes I have the manual. A small white book, "that was righted by the usefulness of proper and wholly the set and unset the device" , if you know what i mean :)
Matt