Hello Guest it is June 19, 2019, 01:40:56 AM

Author Topic: MACHINE DOWN, FAILS TEST, AT WITS END...  (Read 2760 times)

0 Members and 1 Guest are viewing this topic.

MACHINE DOWN, FAILS TEST, AT WITS END...
« on: June 11, 2013, 11:44:57 AM »
My machine is down, has been for 10 days, deadlines are about to be missed, and I’m out of answers….

First, some background…

This all started  over  a year ago, when after an automatic update from Microsoft  (I’m not saying this was the cause, that’s just when it happened, the next day after an automatic update), the ability for my PC to call up hyperlinks from one app to another broke…  Links in outlook express mail would not call up pages in firefox or explorer, so I had to save them to the desktop and then manually load them into the browsers.. The big issue I had, was that the ‘gadgets’ in V Carve pro no longer worked, as they used hyperlinks to call them up.. I needed the keyhole gadget for plaques..  All I would get is a blank page.. After posting the problem on several forums (ie Vectric and CNC Zone), I was never able to solve the problem..

At the time, I had my neighbor (An IT tech of more than 2 decades experience), help me to tke the machine back to before the MS update..  didn’t help..  He came over and did a complete restore, didn’t help.. We went through all the suspect causes, telling XP what to do with hyperlinks and what not.. nothing worked…

This is to be my first summer of hitting local craft shows and fairs, selling my wares…  The first was to be this next Saturday.. I’m not going to be ready.. the following Saturday is another, and unless I can get this machine working again 'soon' I will not have some product I agreed to make for a customer (a local historical group) ready either…

Ten days ago, I decided I could not wait any longer for the gadgets feature to work, and after my machine had some sort of hiccup and destroyed a piece of maple and did a pretty good job on the jig holding it, I told my neighbor that I wanted to wipe the Hard Drive clean and install XP Pro clean from scratch…  So I backed everything up (including a complete disc image of the existing HD), and we wiped the HD clean and reinstalled XP from his custom discs…. Then went to Dell, and downloaded and installed all of their recommended drivers for this machine..  Reinstalled Mach3, etc… My machine has not worked since…

Okay, that’s the back ground..  Now the problem and the history of what I have tried to do since….

When I hold down a jog key and keep it held down, after ten or fifteen seconds, I start to hear the motor step.. at first a couple steps a second, then gradually ramping up in speed to where the machine moves maybe a quarter to a half an inch a minute…  All the motor settings are as they should be…. The ‘sounds’ that Mach3 makes (ie when the e stop is activated), are very distorted..

Computer Specs..
DELL OPTIPLEX 745 SDT INTEL CORE 2 DUO 2.13GHz 80GB 2GB DVDRW XP PRO

When I do a driver test, the driver  initializes and the sound made is clear and undistorted, as soon as Mach3 takes control, the sound is distorted…  It initially list the pulses per second as about 95 (which is in line with the jog speed performance of the machine), the graph only goes about an eighth of the way across the screen, and it says ‘pulsing too fast’..  then  a few seconds later it says pulse rating ‘system excellent’…  but the ‘pulses per second’ still reads about 95-97..




If, I then select  a kernel speed of 35k, the ‘pulses per second’ then jump up to about 35,000 and the graph looks normal..



 If I switch back to a kernel speed of 25k, then the ‘pulses per second’ reads about 25,000 and the graph looks normal…



At this point, I decided there was a problem with my computer, that the clock was too unstable to pass the mach3 test, and this was why the sound was distorted too, that Mach3 was just taxing the system too much..

So, I bought  another  reconditioned Dell PC..
Dell Optiplex 960 Tower Core 2 Duo 3.16GHz 160GB 4GB DVD KB and MS Vista Business

It came with Vista Business, and preferring XP Pro, we installed XP Pro SP2, and then I downloaded all of Dells drivers for that machine, reinstalled Mach3, rebooted, and ran the driver test (I had not even yet hooked up the Parallel Cable to the machine)…

EXACT SAME PROBLEM WITH THE DRIVER TEST!!

SAME SOUND DISTORTION (albeit not as bad, probably due to the much more powerful processor)!!
And the machine performs exactly the same way…

The strange thing is, that with the original computer, for a moment  once a few days ago, the machine jogged normally…  but after a reboot, to see if it was fixed, it was back to the same problem…

This seems to be almost certainly a driver problem in XP Pro.. but  I’m at a loss where else to look.. In the hardware devices, all drivers are installed… Both PCs work perfect in every other way.. Even the issue with hyperlinks in V Carve Pro is fixed…  I have uninstalled and reinstalled the Mach3 driver so many times it’s ridiculous… Nothing helps..  The IT tech is at a loss… I’m at a loss…

I just can’t get the Mach3 driver to work, and thus the machine to work…

So, I’m hoping and praying that someone here has some ideas….
« Last Edit: June 11, 2013, 11:48:09 AM by Mountaincraft »

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #1 on: June 11, 2013, 01:39:46 PM »
The sound going funny whilst Mach is starting is nnormal so not a problem.

Have a look in the Bios and see what your parallel port mode is set to.
Hood
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #2 on: June 11, 2013, 01:52:18 PM »
Hi Hood..

The sound thing did not used to be like that.. and it is not on the lap top which is not near as powerful as either of these machines... So that's why I thought it curious.. 

We have tried every selection available in the BIOS... same result..

I talked to my neighbor this morning, and he mentioned that he was doing the install from a disc image, because it is faster... and not from an actual installation DVD...  We might try that too..  Does this sound like it would cause problems?

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #3 on: June 11, 2013, 01:59:55 PM »
The ringing sound whilst Mach is starting has happened for a long time on the desktop  computers I have here and at the workshop, not sure if it always was that way or not as I never usually have sound cards enabled on my computers that I have Mach on.

It may be something to do with the install being from an image but would say its probably not that likely.
You could try going into device manager and deleting the Mach Pulsing Engine. Restart Mach then go into the Mach folder and run the driver test. It will show pulsing too fast errors but let it run. Once completed you can run it again and see if it has made a difference.

Hood

Offline poppabear

*
  • *
  •  2,231 2,231
  • Briceville, TN, USA
    • View Profile
    • S S Systems, LLC
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #4 on: June 11, 2013, 10:59:07 PM »
Hummmmmmm,  to me it sounds like you download, or re-activated one of the "Mach Exploader" programs...

i.e. Real Movie player, (sometimes skype), and there are others, some are deadly to Mach3, ESPECIALLY ones that do DMA calls.........    If your RAM is low (not greater than 2gig), then the ap makes calls to the harddrive which makes a DMA call.......   There was an OLD document, I forgot where it is on the site. But it shows how to "Stream line" XP (some of the same crap for vista etc.)

Look at your "MSCONFIG", and look at all your start up programs........  you don' t need ANY thing but known microsoft system stuff on auto start up.
Look closely at your video system, if you have Video on mother board, (not a separate card), then some of them did wierd stuff (rare).

Once you get your computer UP and running, then bring up Mach3, THEN look at your running processes...
the ONLY thing you want to see in there is Mach3 and Widows System stuff running. IF you see other PIDs and you KNOW you have killed all the start up programs, then find out what is running that is NOT MS system stuff and kill its PID.  ALSO, some Virus software, will KILL mach3........  (since in many ways, the driver of mach3 to all intents and purposes is a virus.  IF you have virus software, it could be containing or killing Mach3 or parts of it....

Scott
Commercial Mach3 & Mach 4, Design/Build/Retrofit CNC and Industrial machines.
http://www.ss-systems-llc.com/
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #5 on: June 12, 2013, 10:04:10 AM »
So... I decided to install Vista from scratch from the Disc that came with the machine... Then spent about 5 hours downloading and installing the drivers from Dell... Then I spent a couple hours installing and reconfiguring the Mach3 Machine Control....

11 hour day... The machine is running again!!!.... Praise God! What a relief!

Now I am pretty sure as to why there were issues.. The fact that we were installing the Operating System from a disc image as opposed to installing it from an install disc.. For some reason, the Mach 3 Driver is very picky about how the OS is installed...

So, after talking to a tech at Dell yesterday morning, I bought a used Dell/Windows XP Pro installation disc off of eBay.. It should be here in a few days... Then I will install it off of the disc onto the old PC, install the drivers and install Mach3 on it... Once I have it running, I will use it on the machine while I do the same thing to this PC I just spent all day yesterday installing Windows Vista on....

In the meantime, I can start installing CAD/CAM software on this new PC and get back to work...  I have to figure out how to get the tool library information for V Carve Pro back in to the fresh install on this machine... I'm missing a S/N for Photo V-Carve, so I have to figure out how to find and get the old data from outlook express on the backup disc image onto this computer...  I lost the last wo months worth of projects, so I have quite a bit of rebuilding to do yet...

But.........................................
"IT'S ALIVE!!!!!!!"
(and the sounds are all crystal clear again too.. ;D )
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #6 on: June 12, 2013, 12:22:32 PM »
One thing you mentioned in your first post was the problem happened after the MS automatic update. My Dell 8400 XP Pro, service pack 3, 3 gig ram started slowing down to a crawl one day for no reason. After much investigating I found the  automatic update was eating up CPU time. This was something new as I've been using the PC for along time without issue. I read someplace that Microsoft had a bug in one of the automatic updates that caused this problem. The fix was pretty simple... disable the update function. This may or may not be an issue with you but it worth getting the info out there.
Re: MACHINE DOWN, FAILS TEST, AT WITS END...
« Reply #7 on: June 12, 2013, 01:36:17 PM »
yeah, don't want automatic updates.... for sho!
Burn me once, shame on you.. burn me twice, shame on me....
 ;D