Hello Guest it is May 23, 2019, 01:27:09 AM

Author Topic: Feed not changing on Mach3  (Read 4770 times)

0 Members and 1 Guest are viewing this topic.

Feed not changing on Mach3
« on: May 19, 2013, 02:28:49 PM »
I am making my G codes with BobCAD 24.  Up until now everything has been working OK. I think, I have not paid much attention to this issue.

I have been making tests to fine tune my cuts.  To start I have been changing my feed. I did this by re-posting a code, I use BobCAD 24.  Again, I re-post, not editing a used code.

What I noticed is on the Mach 3 screen the feed speed does not change with the new G code.  I can not swear it ever did.

I can change the feed using the Mach screen, but it does not necessarily go to what I want.

Anybody have my answer?

I do have another issue and have a separate post.  Is is dealing with my ARC OK.

Looking for answers and help.

Thanks, Bob
« Last Edit: May 19, 2013, 02:33:31 PM by Fountaine »
Only one way to Get-er-Done......Do-er-Right!

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Feed not changing on Mach3
« Reply #1 on: May 19, 2013, 04:12:24 PM »
You would have to post the code and your xml.
Hood
Re: Feed not changing on Mach3
« Reply #2 on: May 19, 2013, 07:20:32 PM »
Thanks for the reply. I am not sure what you mean on post the code and my xml.
Only one way to Get-er-Done......Do-er-Right!

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Feed not changing on Mach3
« Reply #3 on: May 20, 2013, 02:53:10 AM »
For me to try and find out the problem I really need to try and understand it. The easiest way for me to do so is look at the way you have Mach set up (your xml) and also look at the GCode you are using.
The xml holds all your config and you will find it in the Mach3 folder, it will have the same name as your profile and use a .xml file extension.
Hood
Re: Feed not changing on Mach3
« Reply #4 on: May 20, 2013, 09:03:57 AM »
Hood:  I did not know exactly what xml file you wanted so I copied them all for you.  You will see the tests I was doing.

The files are Moose ### ###.  The first ###s are the feed and the second is the THC ###s

When I start Mach 3 the screen opens with the FRO at 6, when I start a design it does not change to the ##s entered in the feed. Should it?  It does change if I change the feed +/-.  It does not change to where I have it set yet the speed does change.

Is this nothing to worry about or should this be making the entry change?

Thanks for your help.
Only one way to Get-er-Done......Do-er-Right!
Re: Feed not changing on Mach3
« Reply #5 on: May 20, 2013, 09:06:03 AM »
Here is the second file, it would only attach 1 at a time.
Only one way to Get-er-Done......Do-er-Right!

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Feed not changing on Mach3
« Reply #6 on: May 21, 2013, 06:51:10 AM »
Would really need to know which xml you are using, maybe it is shown in the Mach when you open it, in Mill the rofile name is shown lower right, possibly the same in Plasma?
If not then you can get the info from the shortcut you are using to open your plasma, if you right click it and look at properties then target you will see the name of the profile in there.
Hood
Re: Feed not changing on Mach3
« Reply #7 on: May 21, 2013, 07:10:11 AM »
Thanks, it says"c:\Mach3\Mach3.exe.  I have several issues that I am experiencing. I will go to the 2nd after this one.

I do thank you for your help, you have been there for me in the past also.

Thanks,
Bob
Only one way to Get-er-Done......Do-er-Right!

Offline Hood

*
  •  25,811 25,811
  • Carnoustie, Scotland
    • View Profile
Re: Feed not changing on Mach3
« Reply #8 on: May 21, 2013, 07:18:34 AM »
Ok it sounds like you may be using the loader to then choose the profile to open as the exe is Mach itself. If however you are using a specific shortcut then maybe you are not seeing the end of the target text, if you click in it then use the left arrow on your keyboard it will scroll along to the end and you will then see the name of the profile.
It should look something like this (see screenshot) the important info is the bit after the /p

Hood
Re: Feed not changing on Mach3
« Reply #9 on: May 21, 2013, 07:58:41 AM »
It is a loader. I checked the target and what I sent was complete.  I went to the Mach 3 program and sent a shortcut to the desktop.  It also showed a loader with the same target.

I also looked at the program itself and it had a target that was different....It was c: then a lot of microsoft\program\......with \mach3.exe at the end.

Sorry I do not know how to get you what you want.  What's next?
Only one way to Get-er-Done......Do-er-Right!