Hello Guest it is December 11, 2019, 05:55:18 AM

Author Topic: Help with SmoothStepper configuration  (Read 5416 times)

0 Members and 1 Guest are viewing this topic.

Help with SmoothStepper configuration
« on: May 16, 2013, 03:58:57 PM »
I have a PC running Windows XP, latest version of Mach3 software, latest version of SmoothStepper driver and plug-in, Probotix PBX-RF RF Isolated CNC Breakout Board, three MondoStep 7.8 Bi-Polar Stepper Motor Drivers, and three NEMA 34 Frame stepper motors. Before yesterday, the breakout board was connected to the PC's parallel port. After three ruined jobs in a row, I tried to find out what's wrong with my system. I decided to use USB SmoothStepper board. After configuring my system to use USB SmoothStepper board, I got my system working but there is problem with E-Stop tripping after the job is completed. I tried to set debounce  in Mach3 configuration window to 500 and 30 but E-Stop still trip. The manual for USB SmoothStepper board may need to be updated. How can I stop the E-Stop from tripping? I think that there is no common ground between PC, USB SmoothStepper board, and the CNC router. Do I need a separate power source for the USB SmoothStepper board? What about Kernel Speed in Mach3 configuration window? I set it to 45,000 Hz.

Offline Chaoticone

*
  • *
  •  5,633 5,633
  • Precision Chaos
    • View Profile
Re: Help with SmoothStepper configuration
« Reply #1 on: May 16, 2013, 05:47:19 PM »
Your Kernal speed won't matter if using the SS.  The debouce does not effect the SS either.  you will need to add your debounce or noise filtering in the SS config set up page.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Help with SmoothStepper configuration
« Reply #2 on: July 31, 2013, 05:56:44 AM »
I had problems with occasional missed steps using the parallel port on a laptop. I decided to try a smooth stepper to see if it would cure this problem. What happened was that after installing the smooth stepper if I used my usb joypad I started to get random continuous jogs in axes that had not been selected or overspeeding of the steppers where the DRO in Mach3 showed the axis moving but the motors were being driven too fast and were locked and growling. Thought about it for a day or two, tried various setting changes and discussed the problems with a workmate. Suddenly had the thought "what is happening to the usb port power". It seems that when the smoothstepper was in use alone there was just about enough power to work the board. When the joypad drew some power as well the demand on the usb power exceded what was available and the drop in voltage that resulted caused the random problems.

I put a powered usb hub between the laptop and the smooth stepper and the joypad and cured the problem. It seems from what I have read in other threads that similar problems are happening with desktop machines as well as laptops. Since the smooth stepper manual has not been updataed since 2008 as far as I can tell it does not surprise me that this fix is not written up. It mentions external power supplies but does not state how important maintaining the voltage to the board is.

Hope this helps others with these random problems.