Hello Guest it is April 13, 2024, 06:09:59 PM

Author Topic: Homing slave axis revisited  (Read 4673 times)

0 Members and 1 Guest are viewing this topic.

Homing slave axis revisited
« on: May 14, 2013, 06:47:46 PM »
I know this topic has been beaten to death but I'm having an issue that hasn't been covered in earlier discussions.
I have a new CNC router. Mach3, G540 and an external BOB (PMDX-108). Proximity switches are all working and seem to be configured correctly. I'm using the BOB for the switches. The ref all home worked before but has somehow gotten messed up and no longer functions. My assignments are a bit nonstandard.
X is left/right short axis 24" on my machine.
Z is up down
Y is forward/backward 48" on the long axis

X has sensors on either end of travel wired together and configured as both home and X ++limit and X--limit
Y has sensors on either end wired together plus a separate A sensor defined separately.
X is configured as both home and Y++limit and Y- -limit
A is configured as A home on M4 and the sensor is on the same side as the A motor

Homing Z works fine.
Homing X works fine.
Homing Y works but does not square the gantry.

Code is

Ref All Home Homes Y first then A but leaves M4 sensor tripped and turned on. It trips the M4 switch, stops but does not back off the sensor leaving the M4Home sensor turned on and the gantry not squared.

Any ideas?

Offline ger21

  • *
  •  6,295 6,295
    • View Profile
    • The CNC Woodworker
Re: Homing slave axis revisited
« Reply #1 on: May 14, 2013, 09:53:30 PM »
Try RefCombination(10)

NOT RefALLCombination

Also, in General Config, make sure "Home Slave with Master" is NOT checked.

2010 Screenset

JointCAM Dovetail and Box Joint software
Re: Homing slave axis revisited
« Reply #2 on: May 15, 2013, 07:25:12 AM »
Try RefCombination(10)

NOT RefALLCombination

Also, in General Config, make sure "Home Slave with Master" is NOT checked.

It is refcombination in the code, I posted it from memory and Home Slave with Master is not checked. Already experimented with that one.

Weird thing is that the M4Home will not trigger an eStop like it did before. That's what caught my attention.

Re: Homing slave axis revisited
« Reply #3 on: May 15, 2013, 11:03:06 AM »
I think I may have figured it out. Time will tell.

I was really tired yesterday after loosing several hours of work to a smoothstepper screwup that turned into a huge gouge in my semi-finshed sample sheet for a local cabinet shop. Since the A (slave) motor has no actual limit switch it seems normal that tripping the home switch defined for A would not generate an eStop. That's why the A "prime" sensor remains lit without an eStop. The problem seems to be that I got lost in all the settings and tried so many different combinations of code I failed to notice that when the refcombination(10) executes it does indeed back off the A side prime sensor. But when the Y squares later it pulls the gantry sideways and re-trips the A prime sensor because the switches are adjusted incorrectly. If I defined the prime sensor as a limit switch for A it would probably generate an eStop if the M4 prime sensor were tripped, which is probably what I want. I'll try it when I get a chance.

I went down there this morning with fresh eyes and carefully watched it and went thought my configuration again and discovered I had the Homing/Limit setting for the A axis set to reverse the DRO which, of course reverses the homing direction as well. My motors are defined different than the stock 22 tooth XML from cncrouterparts. I swapped X and Y and had to fiddle with A motor directions to get it working correctly. The A motor has to be reversed in relation to the Y motor since it's on the other side of the machine. That got me thinking I had to reverse the DRO in Homing/Limits which homes away from the switch rather than towards it. That's why I got upset and just enabled "Home Slave with Master Axis" and just used the Y sensor. The issue is also that its difficult to square the gantry without moving the tool around and measuring it. I finally measured tool to frame distance across the X axis and found that the sensors were indeed setting Y axis square with the X. So, I think it's OK. I'm re-running the same job this morning and so far, other than the smoothstepper giving me an error every once in a while, its working OK.

Thanks for the replies.