Hello Guest it is December 13, 2019, 09:27:28 PM

Author Topic: mach3turn motors don't work  (Read 2137 times)

0 Members and 1 Guest are viewing this topic.

mach3turn motors don't work
« on: May 12, 2013, 04:09:58 AM »
HI
I hope anyone can help me.
I've just got a proxxon turntable with a cnc kit on it. I've put it all together and installed Mach3turn.
On the controller the fan is working and I put in the values given by the manufacturer in ports and pins.
But the motors don't move. I phoned someone and he said that if I could turn the axes as easy when the controle box is turned on then there is no power getting to the motors.
And indeed there is no sound or movement at all by the motors. So even if I go to motor tuning in Mach3 nothing happens.
Could this be a configuration in Mach3 or just an issue on the printboard. Should the motors make a sound and set even if the controlbox is not connected to the computer?
I measured the voltage with the multimeter on the controlbox which has a 19 volt adapter. When I turn the DC to 50 if have a reading of 20 on the pods that are on the printboard for the x,y and z axes. The motors are 4 lead steppermotors.

Offline RICH

*
  • *
  •  7,380 7,380
    • View Profile
Re: mach3turn motors don't work
« Reply #1 on: May 12, 2013, 06:32:21 AM »
Post a link to the exact cnc kit that you purchased.
Also post your xml file.

RICH
Re: mach3turn motors don't work
« Reply #2 on: May 12, 2013, 07:16:27 AM »
Hi Thanks
This is the link
http://www.usovo.de/shop/CNC-Umbausaetze/Umbausatz-Proxxon-PD230-E-CNC::371.html
And i have attached the mach3turn xml file
Levi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3turn motors don't work
« Reply #3 on: May 12, 2013, 01:41:15 PM »
Are you connected to the parallel port that is on the motherboard or is it a PCI parallel port?
I looked but I dont see a link to any documentation on that site, if you have a pdf can you attach it please.
Hood
Re: mach3turn motors don't work
« Reply #4 on: May 12, 2013, 03:59:22 PM »
i thanks for your reply
I have an LPT port on the motherboard.
I've scanned the print I got with the machine.
On number 4 are the pins
Levi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: mach3turn motors don't work
« Reply #5 on: May 12, 2013, 04:41:24 PM »
Could you have the Step and Direction pins backwards? I dont speak/read German but Richtung seems to be Direction and I presume Takt is Step, if so then you have the pins round the wrong way.
Hood

Offline RICH

*
  • *
  •  7,380 7,380
    • View Profile
Re: mach3turn motors don't work
« Reply #6 on: May 12, 2013, 09:00:49 PM »
Sorry but need the info in English  and the link was of no use.
RICH