Hello Guest it is September 22, 2019, 12:34:25 AM

Author Topic: My retrofit nightmare  (Read 20578 times)

0 Members and 1 Guest are viewing this topic.

Offline mvoros

*
  •  141 141
    • View Profile
Re: My retrofit nightmare
« Reply #70 on: May 24, 2013, 11:28:43 AM »
Hello Hood,
I found a website regarding the "Guide for implementing the MPG2 and configuring Mach" for it. The only difference I can see is that instead of LPT2 I'll have it connected to LPT3 that is on the ESS. As of now there is nothing connected to LPT2. Please look at this instruction and let me know if I can follow it to a letter. There are informations on it that I don't yet have.
Mike

http://cnc4pc.com/Tech_Docs/guide_for_MPG4_over_LPT2.htm
« Last Edit: May 24, 2013, 11:31:32 AM by mvoros »

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: My retrofit nightmare
« Reply #71 on: May 25, 2013, 02:46:56 AM »
If you will be using the same switches for limits then you will input the same pins as the homes are for each axis. If you will be using seperate switches then you will enter whichever port and pins you connect them to.

Regarding the ESS, I am not sure if you should have a blank page like that, I would have thought it should have started with default values so make sure it is installed correctly and that you have the drivers installed for it also.

What you do need to set up are the frequencies for each axis you are using. You want to set them to the lowest value you need. ie if for example your steps per unit were 20,000 and your velocity 100 then that would require 20,000 x 100 /60 = 33,333.333333333333 Hz or 33.33333khZ so you would pick the next value in the list above that, from memory I would think 35KHz.
 The controller frequency I would try at 2KHz, the faster you can set it the better things like feedhold will work however if set too high for your computers capabilities then you will get run out of data errors.

Hood.

Offline mvoros

*
  •  141 141
    • View Profile
Re: My retrofit nightmare
« Reply #72 on: May 25, 2013, 08:42:42 AM »
Hood,
I tried to input vales into the plug in config page and to Mach's input limits, it says to reboot Mach. After opening Mach again, none of my settings are there. Is it because I don't have the computer connected?
Mike

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: My retrofit nightmare
« Reply #73 on: May 25, 2013, 10:19:31 AM »
You need the ESS connected before any of its config settings will be taken.
Hood

Offline mvoros

*
  •  141 141
    • View Profile
Re: My retrofit nightmare
« Reply #74 on: May 27, 2013, 10:48:07 AM »
Hood,
I did connect the ESS.
When I open Mach3 (ver R3.043.066) it tells me: "Wake up client board doesn't reply". I've configured Mach to except the ESS weeks ago, but I think it didn't save the settings to the xml. It did show that it found the plug in, and it also showed up in the device page. The ESS plug in version is: -v10hd2.
Now I realise that I have to set up Mach & the ESS again. I read in one of the forums, that Jeff Birt suggested to a guy (Frank), that he should remove the 066 version of Mach, and install 062 instead, because 066 behaves strangely. And I did experience strange behavior in other areas of Mach. Also, when I click on the plugins, the ESS config page, has nothing in it.
Mike

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: My retrofit nightmare
« Reply #75 on: May 27, 2013, 01:52:54 PM »
"Wake up client board doesn't reply"
To me sounds like you do not have the address set correctly in the ESS or in your ethernet connection.
Hood

Offline mvoros

*
  •  141 141
    • View Profile
Re: My retrofit nightmare
« Reply #76 on: May 28, 2013, 12:39:00 PM »
Hi Hood,
Well I managed to get the ESS to work with Mach ver. 3.043.062. The problem now is that I can't get Mach to reset, and therefore my configurations are not saved after clicking on apply. The reset botton is flashing and has green border around it. It says: Press reset, emergency mode active.
What could be the problem?
Mike

Offline Hood

*
  •  25,853 25,853
  • Carnoustie, Scotland
    • View Profile
Re: My retrofit nightmare
« Reply #77 on: May 28, 2013, 01:22:00 PM »
You will need to tell Mach/ESS which port and pin your E-Stop is connected to. If you dont have one at the moment (not recommended) then you can change the active state of the E-Stop in Ports and Pins, Inputs page. That will allow you to take Mach out of Reset.
Hood

Offline Chaoticone

*
  • *
  •  5,589 5,589
  • Precision Chaos
    • View Profile
Re: My retrofit nightmare
« Reply #78 on: May 28, 2013, 01:23:55 PM »
Mike, I'm only guessing but it could be that you have an estop or limit switch active.  You might be able to go into ports and pins and change their active state to get to the point you can reset.  You should probably make a note of how they are set before the changes you make in case you have to revert.  Looking on the diagnostics screen to see if any limits of estops are active should help you narrow it down a little before you adjust your switches active state.

Brett  
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!