Hello Guest it is December 15, 2019, 06:32:28 PM

Author Topic: no connection between the machine and pc, help please.  (Read 5147 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #10 on: May 02, 2013, 03:03:18 AM »
Can you tell me what hardware you have connected, ie type of breakout board, type of drives etc.
Hood

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: no connection between the machine and pc, help please.
« Reply #11 on: May 02, 2013, 04:08:49 AM »
there is no led for the limits and home.

parallel port on diag page of mach3 shows only 7 or 8 green led, that is all what i have..

Are you sure you ACTUALLY have a problem? Your screenshot contradicts your first quote and if your second quote is about the "Port 1 Pins Current State" LEDs then ignore them - they don't work - never have.

From what you've said so far there doesn't seem to be anything wrong.

Ian

Offline Robhi

*
  •  138 138
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #12 on: May 02, 2013, 07:22:10 AM »
Hi

first for Hood,

I have BOB breakpout board, sound logic, 1.9, servo motors, gecko drives for servo motor, 320x, but till now they are not mounted. Just I would like to test the BOB, ( I have 2 of them, old one which works well before, new one, Both of them do not work)

For Ian,

Normally as you know of course, when we touch any limit or home switch, the yellow led on the diag page should come on,
my home and limit do not come home, whether they are configured active or high.
the Estop too, does not work, if you push it nothing happened, as the limit and home, normallay mach3 must stop when we push Estop, Mine works with or without, does not work with or without Estop.

hoping that I am a little bit clear than before.

Thanks for both of you, and the other members too.
Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #13 on: May 02, 2013, 03:47:42 PM »
Ok I am not quite sure what you have connected up and what you are expecting to see.
Do you have the limit switches, E-Stop, Drives/motors etc connected?
Hood

Offline Robhi

*
  •  138 138
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #14 on: May 02, 2013, 04:38:03 PM »
hello,

only Estop, limit and home swiches are mointed.
when the test is ok, I will mount the reste, drives and motors. but till now it doen not work as it is recommended in BOB breakout documents.

normally, when I touch any limit, the led that correspond should come on in the diag page,. only leds on the bob itself that work well.

i do not why.

thanks Hood
Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #15 on: May 02, 2013, 05:21:53 PM »
Ok so if BOB LEDs are ok then that means the Bob is getting the signals, so assuming you have Mach configured to the correct pins then it leaves two things, cable not a direct connected cable or your port address is wrong.
You mention you have a few LPT ports showing in device manager, are there corresponding port connections on your computer? Are there two seperate PCI cards or is it a dual card?

Hood

Offline Robhi

*
  •  138 138
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #16 on: May 02, 2013, 05:26:16 PM »
Hello

I just have changed the PC, and everything working well, so the port on that PC does not work.

So thanks for all of you for your help, Hood Ian as well as all other members.

just one question please , on this PC when I run driver test, it is written too fast, then excellent.. does that make a problem in the future, tuning motor etc...?

thanks again
Robhi

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #17 on: May 02, 2013, 05:28:06 PM »
What does the line look like in driver test, is it smooth or does it have spikes on it?
Hood

Offline Robhi

*
  •  138 138
    • View Profile
Re: no connection between the machine and pc, help please.
« Reply #18 on: May 02, 2013, 05:28:34 PM »
I have just replied and everything is ok... you are right Hood port work bad on that PC

thanks again

Robhi