Hello Guest it is July 08, 2020, 07:55:00 AM

Author Topic: Have a few problems, need some help please.  (Read 4612 times)

0 Members and 1 Guest are viewing this topic.

Have a few problems, need some help please.
« on: April 24, 2013, 09:05:17 AM »
I am using Mach3 with lazycam. I have the license for both of them. Now here are the problems:

1) I can not get lazycam to post a g-code into Mach3. It keeps showing the message "No Mach3 found running". How can I fix this?

2) I started to load my g-code manually from mach3 and that's fine except that whatever I loaded only about half or so would show up. I have noticed that my g-code only went to 5000 lines. So i uninstalled both Mach3 and lazycam then reinstalled them. Now my g-code limit seems to be only 2500 lines.

I am no where near an expert with these programmes. I have went through the entire lazycam manual and also the mach3 manual i was given when I bout the program. If anyone could help I would greatly appreciate it.


Thanks,
John

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Have a few problems, need some help please.
« Reply #1 on: April 24, 2013, 02:28:30 PM »
Make sure Mach still shows your licenced, you will see that either at the top of the screen if a recent version or from the Help menu then About.......

If your name is not there then it would seem you have deleted your licence when you installed Mach, you need to find it and place it back into the Mach3 folder and restart Mach, same with your lazycam licence.

Hood
Re: Have a few problems, need some help please.
« Reply #2 on: April 24, 2013, 02:44:31 PM »
Both of my programmes show that i am licensed. Any other suggestions?

Thanks,
John

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Have a few problems, need some help please.
« Reply #3 on: April 24, 2013, 03:09:29 PM »
Cant help with LazyCAM I am afraid as I have never used it. :(
Hopefully someone else who has will help you out.

Hood

Offline RICH

*
  • *
  •  7,410 7,410
    • View Profile
Re: Have a few problems, need some help please.
« Reply #4 on: April 24, 2013, 09:07:40 PM »
 I can not get lazycam to post a g-code into Mach3.

If you don't install LazyCam when the Mach installation is completed ( you used to be prompted if you want to install it ) LC will not automaticaly post the code to Mach. ie; You install LC later on. Have you tried loading LC via the File tab >LazyCam...  when Mach is opened?

It been a while and that is all I can recall.

RICH
Re: Have a few problems, need some help please.
« Reply #5 on: April 25, 2013, 08:03:57 AM »
I did install both programs at the same time, and when ever I open lazy cam I load from the mach3 screen.

thanks,
John
Re: Have a few problems, need some help please.
« Reply #6 on: April 25, 2013, 08:11:34 AM »
Is there any other programs that might work with my 3040T triaxial engraving machine? The command codes my machine can read are g-code/.nc/.ncc/.tab/.txt.

thanks,
John

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: Have a few problems, need some help please.
« Reply #7 on: April 25, 2013, 09:51:29 AM »
Is there any other programs that might work with my 3040T triaxial engraving machine? The command codes my machine can read are g-code/.nc/.ncc/.tab/.txt.

Not really sure what you're asking here John. It's Mach3 that reads and processes the gcode not your machine. If you're asking for a recommendation for a replacement for Mach3 you're probably asking in the wrong place.

That said arn't you giving up a bit quick? You only posed your question yesterday. I've never used LC so I can't help you with that one but why not try to load the roadrunner.tap file first and see if you can load all that (it's 4000 odd lines long). (Let's take LC out of the loop for a moment - one thing at a time).

Ian

Offline RICH

*
  • *
  •  7,410 7,410
    • View Profile
Re: Have a few problems, need some help please.
« Reply #8 on: April 25, 2013, 11:58:14 AM »
Click the tab in LC.................Setup>Posting Options ...........
Do you have a check for "Send File to Mach3 when posted"

But, I suggest you get the number of lines problem ironed out first as Ian replied.

RICH

Offline Chaoticone

*
  • *
  •  5,629 5,629
  • Precision Chaos
    • View Profile
Re: Have a few problems, need some help please.
« Reply #9 on: April 25, 2013, 12:13:56 PM »
Also, what OS are you running on the PC.  LC will only post to Mach if running in XP.  Otherwise you will have to save your code then open it from Mach.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!