Hello Guest it is June 24, 2019, 05:53:21 AM

Author Topic: Spindle index on Optimum D280x700 Vario Lathe  (Read 11065 times)

0 Members and 1 Guest are viewing this topic.

Re: Spindle index on Optimum D280x700 Vario Lathe
« Reply #30 on: February 22, 2013, 12:17:43 AM »
So I connected pin 2 and 15 on the controller to the enable+ on the drives and pin 15 to enable- on the drives.
In mach I setup port 10 pin 0 to enable 1 and port 10 pin 1 to enable 2.
I can see the leds go on and off, but cannot measure anything on the pins nor does it affect the drives.
I also connected pins 1 and 5 on input0-15 to a mushroom switch and set estop in mach to port 10 pin 0.
Nothing is registred here either.
The good news is that the encoder seems to be working although mach fails g76 with "external estop requested"
Oh the joy...

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Spindle index on Optimum D280x700 Vario Lathe
« Reply #31 on: February 22, 2013, 02:45:21 AM »
Ok first do you have a 24v supply to the CSMIO outputs? Pins 1, 4, 7 and 10 are to be connected to +24v and pins 14, 17, 20 and 23 to the 0v of your supply.
Regarding the Index, in the plugin invert  the encoder input, sounds like you have it the wrong way round, see screenshot.

One thing I should also say, any time you go into any of the config menus make sure the Reset in Mach is flashing first or your computer will hang.
Hood
Re: Spindle index on Optimum D280x700 Vario Lathe
« Reply #32 on: February 22, 2013, 01:17:54 PM »
Thanks again!

Attached is first impressions.  :D

So for the e-stop I want to feed 24v into input pin 1 and 0v to input pin 5? (it is!)

--
gallenat0r
« Last Edit: February 22, 2013, 01:22:37 PM by gallenat0r »

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Spindle index on Optimum D280x700 Vario Lathe
« Reply #33 on: February 22, 2013, 01:47:09 PM »
Looks a nice thread :)
Yes that is correct, you would run +24v to your E-Stop and then from it to an input on the CSMIO then as long as you have the 0V of your 24v supply connected to the terminals marked - (pin 5 for inputs 0-7, pin 6-13 for inputs 8-15) then it should work fine.

Hood
Re: Spindle index on Optimum D280x700 Vario Lathe
« Reply #34 on: April 10, 2013, 02:40:35 PM »
I had some more time to fiddle with it but am having trouble with x-pullout when cutting threads.
I've seen elsewhere that it's common problem with csmio vs mach3.
Do you know how to solve this?

--
gallenat0r

Offline Hood

*
  •  25,844 25,844
  • Carnoustie, Scotland
    • View Profile
Re: Spindle index on Optimum D280x700 Vario Lathe
« Reply #35 on: April 10, 2013, 03:18:04 PM »
You can go back to ver 022 and try it, whether you will hit other problems I do not know as I only had that version loaded for a short time.
Hood