Hello Guest it is July 08, 2020, 12:40:48 AM

Author Topic: initial machine setup - machine coordinates/soft limits javascript:void(0);  (Read 2986 times)

0 Members and 1 Guest are viewing this topic.

now that I've cut a few parts I want to use the entire table size and protect myself with soft limits.  my router has no limit switches.  it seems to me that I need to move the spindle to the lower left corner and somehow set the machine coordinates to zero.  for the life of me I can't do this.  currently it shows x=918, y=214, z=25 while sitting in the far corner [want it to read x=0, y=0].  my soft limits won't run because they are off the scales.
one set of instructions said to REF ALL, toggle RDO to machine coord [red box], then zero each axis.  this DOESN'T work!  neither does anything else I've tried, and tried, and tried.
I don't know at this point where the machine coordinates I have came from.  at one point I had soft limits working when I carefully defined my table as just 12" x 12" [just playing it safe].
am I doing something wrong?  am I on the wrong path?  ahren from CRP told me he sets his machine up like this [no limits, just soft limits], so that's not the problem.

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Ok if you move lower left lower corner and Z fully up and then press RefAll button the Machine coords should zero. That is the only way you can zero the machine coords, well it can be done in VB but .... Anyway if the machine coords do not zero then you may have one or two things wrong, both are on Homing and Limits page (from Config menu) Make sure you have the Auto Zero option chosen and secondly make sure you do not have a value set in Home Off box.
Then for your soft limits you want X and Y Min and Z Max set as 0 and X and Y Max and Z Min set to their respective axis travels, Z being a negative value.
You should then be able to jog to lower left corner and when you press RefAll the machine coords will zero and you should now be able to use Soft Limits.

Hood
« Last Edit: April 06, 2013, 05:28:04 AM by Hood »
IT WORKS!  it was zeroing out the home coordinates that did it.  when I added them back in the non-zero stuff returned, but I don't need the home def. anyways.
why isn't this mentioned in your documentation?  also add that axis limit units are that used for motor calibration, not current part.

Offline alenz

*
  •  137 137
    • View Profile
why isn't this mentioned in your documentation?

I believe you may have just unknowingly complemented Hood. :D He is not responsible for the Mach documentation. He is a fellow member of our forum. Due to his outstanding knowledge of Mach and his willingness to spend his time sharing and helping others he is sometimes mistaken as a member of the official Mach Support Team.  I suspect very few members can honestly say that they haven’t been helped at one time or another by Hood’s posts.
al
« Last Edit: April 07, 2013, 12:54:28 AM by alenz »
Actually, in Section 6.2.2.2 "Reference", zeroing machine coordinates is in the first bullet item, but never called out as such for us mere mortals to recognize. (grins) Thanks to Hood I was able to interpret this cryptic passage and successfully reset my machine coordinates. Thanks!!

Mike
I stumbled onto a Youtube video that really cleared up the confusion in my head concerning the coordinate systems. There are several videos beginning with initial setup.
The one about coordinates is at: http://www.youtube.com/watch?v=ma7lMocQbv0
Well, it didn't post as hypertext so just copy and paste the URL.

I hope this will help others as much as it helped me understand the subject (I am pretty new to CNC).

Regards, Tom