Hello Guest it is October 18, 2019, 06:05:48 AM

Author Topic: Rapid G1 Feed Changes (and not even changes) Causing Decel/Stutter  (Read 1921 times)

0 Members and 1 Guest are viewing this topic.

This G-Code runs nice and smooth (this shows it's not a "lookahead" setting issue):
x0.002
x0.004
x0.006
x0.008
x0.01
... (all the way to x10)

This G-Code runs horrible, causes stuttering like it's decelerating to 0 each time F is changed:
x0.002 f20.002
x0.004 f20.004
x0.006 f20.006
x0.008 f20.008
x0.01 f20.01
... (all the way to x10)

And what's interesting is that even this code causes the same stutter just by having F set without the value even changing:
x0.002 f20
x0.004 f20
x0.006 f20
x0.008 f20
x0.01 f20
... (all the way to x10)


Is this an issue that can be resolved with modifying settings in the XML file? Would it require using the no-longer-used Tempest planner? or am I SOL until Mach4 comes out assuming that fixes it? Adaptive HSM G-Code will not run efficiently unless changes in feedrate are handled smoothly.
Re: Rapid G1 Feed Changes (and not even changes) Causing Decel/Stutter
« Reply #1 on: April 02, 2013, 09:51:41 AM »
The feedrate should be modal.  Changing/setting the feedrate on every line will cause a slight hesitation.  It takes time to set the feedrate.  Feedrate should be modal and called on the first feedrate line.  Unless Mach4 decreases the time it takes to process a gcode line, I doubt it will be any different.
« Last Edit: April 02, 2013, 09:54:01 AM by rrc1962 »

Offline BR549

*
  •  6,902 6,902
    • View Profile
Re: Rapid G1 Feed Changes (and not even changes) Causing Decel/Stutter
« Reply #2 on: April 02, 2013, 10:06:31 AM »
Are you running in LPT mode or use an outside controller?  The problem is the micro segmented code and the time element to get everything done smoothly.

IF the change of feedrate of .002 IPM in a move of .002" is a problem then you are using the wrong control software. Mach3 will never be able to handle that on its own ,MAYBE with an outside controller as the controller does all the timing work and can run MUCH faster internally than Mach3.



Just a thought, (;-)

(;-) TP
Re: Rapid G1 Feed Changes (and not even changes) Causing Decel/Stutter
« Reply #3 on: April 02, 2013, 01:11:24 PM »
This issue has just been raised recently on two other forums, and it appears the issue is likely related to running an older version of M3.  Try updating to a newer version and see if it runs better.

I just tested some code with a feed rate on each line, and version .029 runs so badly and slowly that I am too old to wait for it to complete.  The same code with version .062 ran in 21 min. 12 sec.   For those wanting to test for themselves, the code I used can be found here: http://hobbycncart.com/forum/63-151-28 - thread # 543.

Regards,
John Champlain