Hello Guest it is June 24, 2019, 10:37:50 AM

Author Topic: FRO % zero setting for brain  (Read 8459 times)

0 Members and 1 Guest are viewing this topic.

FRO % zero setting for brain
« on: March 28, 2013, 10:23:29 AM »
Hello Sir..
I am using digital feed rate rotary switch to control the feed rate of my CNC.. I use 4 input pins from parallel port for this switch and I wrote some brain for controlling feedrate. But I can't write the brain for feed rate % to zero in my brain.. I want to use feedrate zero setting in my machine because I want to stop my axis sometimes using with feedrate switch in zero position.. How can I do for this setting.. Please hep me.. Thank so much..
High Tech Key

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: FRO % zero setting for brain
« Reply #1 on: March 28, 2013, 02:51:04 PM »
Just write a 0 to the FRO DRO via a formula in the Brain.
ie it would go something like this
Input > No Operation, Pass Signal > Formula > FRO DRO

The formula would simply be a*0

Hood
Re: FRO % zero setting for brain
« Reply #2 on: March 30, 2013, 06:01:38 AM »
Thank Sir for your reply.. But I already try with your method.. It can't work in zero feed rate.. I need to set at least 1% of feedrate in my mach3.. I attach a photo for Feed rate of my mach3.. This 1 % is the minimum % of my mach3.. I can't decrease this 1 % to zero % using the (-) down button.. So, I set the 0% in my brain, the feedrate don't change when I set the zero % feed rate of switch position.. Do I need to change some setting in my mach3 to use zero feed rate? Please advice me.. Thank for your kindly reply..
High Tech Key

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: FRO % zero setting for brain
« Reply #3 on: March 30, 2013, 06:07:05 AM »
What version of Mach3 are you using?

Hood
Re: FRO % zero setting for brain
« Reply #4 on: March 30, 2013, 08:29:33 AM »
My mach3 version is
Version R3.043.022

Thank for your reply.. Please advice me..

High Tech Key

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: FRO % zero setting for brain
« Reply #5 on: March 30, 2013, 08:35:03 AM »
That is too old. Brian changed it for me so that FRO could be set to zero via the pot I use. Previously the feed could not be zeroed but always had a small value of 0.01 or so. If you change to ver 056 or 057 you should be able to set 0.
You will get it here
ftp://machsupport.com/Mach/
Hood
Re: FRO % zero setting for brain
« Reply #6 on: March 31, 2013, 02:22:37 AM »
Thank a lot sir..
My problem is OK now.. First of my error is in my brain.. I write my brain with FRO DRO.. FRO DRO can't make 0 feed rate in mach3. So I modify my brain with Rapid FRO DRO (OEM code 223) and my feedrate switch can set 0 FRO in my mach3.. But I have still some problem. When I set zero feed rate, my axis motor move very slowly.. So I modify my mach3 version (Mach3Version3.043.066) as you say and test again.. All of my problem is OK now.. There is no move in feedrate Zero.. Dear Hood.. Thank you very much for your kindly advice about my problem.. I am very happy now.. Thank again..
High Tech Key

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: FRO % zero setting for brain
« Reply #7 on: March 31, 2013, 05:20:31 AM »
FRO DRO can be set to zero.
Also I suggest you take care as 066 and 067 versions of Mach have issues so that is why I recommended using a different version.
Hood
Re: FRO % zero setting for brain
« Reply #8 on: April 03, 2013, 10:50:49 AM »
Dear Hood..
My feed rate switch has still error in my brain.. My mach3 version is 057 now.. I change 066 version to 057 version because of your advice. I explain about my problem. I wrote the brain for this 4 inputs (11 point) rotary switch. Firstly, I wrote my brain for all inputs condition in only one brain file. But the brain didn't work well. I printed screen shoot for this brain view. This brain can work for 5 group of input and the other left input group is unstable. I send this brain file and two screen shoot brain view for this condition.. Please see and advice me..

I try another method for this switch. I divided 3 brain files and test. In this time, the feed rate up position set the FRO value correctly. But some of the down condition, the value change feed rate 0 in some position of between two brain files.. I also attach these three brains. One of my machine can work well with these three brains files. But my mach3 version for this machine is 022 and I don't use zero feedrate position in this machine.. Please advice me.. Thank you so much..

High Tech Key

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: FRO % zero setting for brain
« Reply #9 on: April 03, 2013, 01:35:42 PM »
Try doing the brain like screenshot.
Hood