Hello Guest it is November 15, 2019, 08:41:00 PM

Author Topic: turret calibration  (Read 2359 times)

0 Members and 1 Guest are viewing this topic.

turret calibration
« on: March 27, 2013, 07:45:15 PM »
hi all,

just got me a converted (mach3 turn) Boxford 240tcl lathe, with an 8 tool turret.

all was going well (ish) until i shut it all down, had some grub then turned it all back on an hour or so later.

it seems to have forgotten what tool is ready to cut. i.e you mdi T0101 and it says "tool is already in position" but tool 4 is there. you type in T0606 and you get tool 1......... and so on.

i have spent many hours looking all over the net to sort this and the only thing i have found is "you need to calibrate the turret" but i cant find out how to do that.

one thing i do remember, is when i first got it going, i got a pop up in mach that asked "what tool position" i looked at the turret and entered in the tool that was in the cutting position. guess i need that pop up to come back, but i can't get it :-(

any ideas?

thx


Blighty
« Last Edit: March 27, 2013, 07:47:41 PM by blighty »

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: turret calibration
« Reply #1 on: March 27, 2013, 08:19:37 PM »
That will likely be your macro that you have to look into.
You could try just entering a tool number into the tool number DRO and see how it goes, ie if your turret is at tool 6 enter 6 into the DRO and then call tool 1 and see if it goes to tool 1
But again that will all depend on how your macro is written as to whether that will work, kind of sounds like your macro is not looking at actual position signals from the turret but possibly just counting.
Hood
Re: turret calibration
« Reply #2 on: March 27, 2013, 08:30:07 PM »
hi Hood,

had a look at your vid last night about how to setup tool offsets. great vid....... that's one headache down :)

i have tried that as in T0606 (tool 1 comes into play) then change the DRO to 1. then type in T0101 it should say "already got it", but it changes to tool 6 again.

think your right about the turret, as in it's just counting.

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: turret calibration
« Reply #3 on: March 27, 2013, 08:35:30 PM »
Probably need to speak to whoever wrote your macro.
One last thing though you could try is enter the number into the DRO then restart Mach and see if it works next time. You may need tool numbers persistent option on General Config.
Hood
Re: turret calibration
« Reply #4 on: March 27, 2013, 08:42:09 PM »
yep done that as well  :(

t0101 tool 6 comes round, type in tool 6, turn it all off. type in t0101 "already got it" toll six still there.

i have seen this "tool numbers persistent option on General Config" mentioned in other threads, but as im at work at the mo i cant nip off to the man cave and have a look.

Re: turret calibration
« Reply #5 on: March 28, 2013, 05:38:37 PM »
i've sorted it  ;D...... well the bloke who i got it from did ;D ;D

you enter M3000 in the old MDI bit and you get a pop up. it says "press enter to index (9=ccw 0=cw) or you just type in the tool number that's in the cutting position and away you go.

i have also ticked  tool numbers persistent option, so now it remembers what ever the last tool was when i turn mach off.



thx for your help :)


blighty