Hello Guest it is July 17, 2019, 09:36:55 AM

Author Topic: Z Value increases on its own - Problem  (Read 2251 times)

0 Members and 1 Guest are viewing this topic.

Z Value increases on its own - Problem
« on: March 20, 2013, 06:00:34 AM »
Hi All,

We have a problem where the Z Value (Only the DRO) suddenly moves up to the THC MAX Level - For no apparent reason...

We manufacture CNC Plasma Machines and the problem only happens now and then... We use same PC's and same software version (Version R3.043.022).

Example: Cutting a square plate 500mm x500mm
- Start to cut - no problem (THC is active)
- THC is working - manually adjust the height with our own THC module
- THC Up/DOWN lights flicker - communication is good with THC controller
- Suddenly the ZValue DRO (not the torch itself) will move up (and quick - within 1s) to Z50 (same as our THC max value) (no THC UP signal recieved...)
- Plate is deforming and torch tip comes closer to material
- Because MACH3 thinks it is already at the THC MAX value it does not move torch up and torch touches plate and Collision switch activates
 or
- if the cut is completed without crashing the torch half way, at the end of the cut the Torch crashes into the plate trying to move to [G00 Z30]... It thinks it's at 50mm above material...

Anybody have any idea about this?

CD


Offline Tweakie.CNC

*
  • *
  •  7,844 7,844
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Z Value increases on its own - Problem
« Reply #1 on: March 20, 2013, 07:42:26 AM »
Hi CD,

I don’t have plasma or use THC so this response is not based on experience...

My best guess, or what I would look for, would be electrical noise pickup on, or associated with, the THC Up signal.

Perhaps check cable runs, shielding, grounding etc. and if necessary fit filters, ferrite's etc.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Z Value increases on its own - Problem
« Reply #2 on: March 20, 2013, 07:49:34 AM »
Thanks, I will try and respond if I cannot find a solution!

Appreciate!

CD
Re: Z Value increases on its own - Problem
« Reply #3 on: March 20, 2013, 08:15:08 AM »
I experienced the same problem but only happened after I used the Feed Hold command then back to cycle start. The z axis slowly creeps back toward the home position. It seems to be a mach 3 problem. The problem occures on several gcode programs. As long as I don't use feed hold... I don't have the z creeping issue. 

Offline Chaoticone

*
  • *
  •  5,524 5,524
  • Precision Chaos
    • View Profile
Re: Z Value increases on its own - Problem
« Reply #4 on: March 20, 2013, 09:03:25 AM »
geh7552, What version of Mach is this creeping happening in?  I would be interested in seeing the code that is used when this happens as well.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Z Value increases on its own - Problem
« Reply #5 on: March 20, 2013, 09:11:01 AM »
Geh7552, what do you mean with "creeping"? Is that only the Z DRO or is it the actual head? With our machine it goes to the max value very quick! I will also see If I can get some G-Code where it happened!

CD
Re: Z Value increases on its own - Problem
« Reply #6 on: March 20, 2013, 12:10:15 PM »
I used the feed hold then jogged the cutter back in the Y axis to clear chips. Then resumed cutting. I noticed the Z axis pulsing 0.001" back to Z home at 2 or 3 seconds intervals. The stepper motor was moving. I reloaded the program and continued without problems. Later I ran another program and used feed hold. After restarting again the Z axis (motor and DRO) was pulsing 0.001" towards the home position.