Hello Guest it is December 06, 2019, 11:10:07 PM

Author Topic: Mach3 only reads MPG pulses in one direction.  (Read 4048 times)

0 Members and 1 Guest are viewing this topic.

Mach3 only reads MPG pulses in one direction.
« on: March 11, 2013, 02:19:12 AM »
Hello fellow Mach3 users,

I am coming to the end of a RF-45 build (and hair on my head) and in the process of configuring Mach3.

The system is using 2 Homan Design BOBs with 1 of them used for MPG pendant inputs and a VFD voltage generator.

The issue I’m having is that when using the MPG wheel the stepper motors will only rotate in one direction. When I swap the encoder pin assignments in Mach3 the motors only rotate in the other direction. The LEDs on the BOB work correctly no matter which direction the MPG wheel is turned, i.e. everything seems ok up to the BOB.

Another interesting thing is that when MPG #2 is setup on the Encoder/MPG’s page in Mach3 using the same pin assignments, the motors rotate both directions as they should. I would happily leave it setup that way however, the axis select switch on the pendant will only work when the system is setup to use MPG #1???

It’s been some months since I previously worked on the project but I think the MPG worked like it should back then. Since that time I have installed quite a few things like home & limit optical sensors, spindle VFD & the latest release of Mach3. Because there have been so many hardware & software changes, trying to back track is doing my head in!

Please HELP! I will be truly grateful ;D

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 only reads MPG pulses in one direction.
« Reply #1 on: March 11, 2013, 03:45:26 AM »
Try going back a version or two of Mach and see if that helps, failing that attach your xml and I will have a look.
Hood
Re: Mach3 only reads MPG pulses in one direction.
« Reply #2 on: March 11, 2013, 06:27:11 AM »
Hi Hood,
Thanks for the super fast reply :)
I did as you suggested and went back to a Mach3 that is about 12 months old (R3.043.050) but sadly, no difference. ???
I have attached my xml file so you can take a look at it.
Thanks again for your help.  ;D

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 only reads MPG pulses in one direction.
« Reply #3 on: March 11, 2013, 07:17:03 AM »
Ok only thing I see is you have 130,000 for counts per unit of MPG1, try changing that to 4, also put the Velocity to 190 like you have for MPG2.


Hood
Re: Mach3 only reads MPG pulses in one direction.
« Reply #4 on: March 11, 2013, 07:39:27 AM »
Hi Hood,
Yea, I tried that but still no good. I notice that when I do a calibrate sequence I end up with those strange numbers??? Not so with MPG2. I think those odd values are a symptom of the problem rather than the cause?
Thanks again :)

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 only reads MPG pulses in one direction.
« Reply #5 on: March 11, 2013, 07:42:34 AM »
Ok, I wonder if its something to do with the Brain, not sure whats in it, will see if its on Peters site so I can look.
Hood
Re: Mach3 only reads MPG pulses in one direction.
« Reply #6 on: March 11, 2013, 07:49:40 AM »
Yea, I wondered about that & even disabled then re-enabled it but sadly my brain needs a little something before I start fiddling with the one in Mach. :) 

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 only reads MPG pulses in one direction.
« Reply #7 on: March 11, 2013, 07:53:11 AM »
Ok was just typing about the Brain and to try disabling but see you have replied saying you already tried.
Not sure what it could be as the xml looks fine.
Hood
Re: Mach3 only reads MPG pulses in one direction.
« Reply #8 on: March 11, 2013, 08:01:45 AM »
Thanks for giving it your best Hood.
I wonder where that brain comes from, I don't think I installed any plugins. Is it Mach standard issue?

Offline Hood

*
  •  25,856 25,856
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 only reads MPG pulses in one direction.
« Reply #9 on: March 11, 2013, 08:38:54 AM »
Just looked and the ModIOMPG Brain is standard issue with Mach it seems so unlikely you are needing it.
Just out of curiosity can you quickly open a different profile and set up an axis and the MPG in it and see if it works. May be some sort of corruption in your xml.
Hood