Hello Guest it is June 06, 2023, 10:31:24 PM

Author Topic: New (to me) Galil system, many questions  (Read 2827 times)

0 Members and 1 Guest are viewing this topic.

New (to me) Galil system, many questions
« on: March 03, 2013, 08:48:17 PM »
Where to start....
I picked up a used Wells-Index 883 with a Galil 18x2 4 axis controller (currently using 3 axis) and ICM-1900 interconnect module.  It is a retrofit as the 883 actually came from the factory as an NC system in 1979 so I'm trying to reverse engineer what they did in the retrofit.  The CNC software is WinGCNC.  My end goal is to try and get this operational with Mach as I'm much more familiar with it.  I've been using it on my Sherline for many years, basically just want the same interface on a bigger machine.

So, I wired it all up as he had labeled the wires and found my X and Z drive would 'run away' to the limit switches where they would stop.  MT -1,1,1 would fix the X but every time I rebooted the computer it was back to MT 1,1,1   Appears the limit switches are connected to the NC104 solid state servo controllers so it would just run up against the limit switch and stop.  Starting with the X I tried everything in the Galil instruction book, reverse A+ and A-, reverse channel A and B and finally reversing the motor leads.  The last was a mistake as it looks like each limit switch feeds a positive and negative 'clamp' on the servo controller.  Took me about 2 hours to disassemble the mill enough to 'un bury' the axis due to severe binding and repair the limit switch.  I'm guessing that limit switch was sending the signal to stop the servo but in the opposite direction it was now going.
After trying everything my last effort was to open the servo and check the pin outs on the encoder then ohm everything back to the controller.  How they had this working is beyond me.  The wires are in pairs and they had A+ paired with Index- and so on.  I'm guessing they just moved wires until it worked then left the labels (now incorrect) on the wires.....anyway, I finally got X working right.  Moved on to Z.  Z would run away to the limit switch then stop. If I gave it a MT 1,1,-1 it would just run away in the other direction to the other limit switch.  I opened the encoder and it appeared right but I took all the leads off the encoder and started ohm'ing/connecting again.  I'm not sure but I think they had the +5 and ground backwards.  After putting it all back together again it seemed to work fine however, after rebooting I find I now have to enter an MT 1,1,-1 every time to make it work.  I know the encoder is now wired correctly.  I did each wire separately and double checked my work.  I'm ok with just giving it an MT 1,1,-1 but can't seem to figure out how to make it 'stick' as it defaults back to MT 1,1,1 at every reboot.  This is my first experience with Galil so I'm sure there is a way....
So now, once I enter the MT 1,1,-1 all axis move and the WinGCNC software can be used.  It's been many months since I was able to mess with my Sherline but I'm almost certain the X and Y axis are backwards.  Z negative moves the cutter down, that seems right.  Jogging X negative moves the table left and negative Y moves the table toward the operator.  I could swear those are backwards as direction is supposed to be in reference to the cutter, am I wrong or does something need tweaked/changed.
Next I moved on to the inputs and outputs.  It has one input coming from what looks like the either 'motor on' or 'tool change'.  I'm having a bear of a time figuring out the original electrician schematics on this thing.  They are much different than electronics schematics.  I notice in the Galil book under the inputs section it says something about connecting an external power supply to the 1900 at pin INCOM but the description of that pin says Input Common, No Connection.  Not sure what to do here as I've got axis movement but can't get the motor to turn on.  I'm guessing that line is now coming from the switch used to turn the motor on that is on the mill head but I can't make Input 1 change states (constant zero volts).
On the outputs I've got Out 1 and Out 2 (motor forward and motor reverse) wired and can change their states with M8, M9, M10, M11 but the motor doesn't turn on.  I'm guessing that Input 1 has to change states first and I'm lost on how to make that happen.  Is there a way to get in the Galil config and see what that input is used for so I might be able to figure out where I should be looking?
Once all that's done it's just the migration to Mach and I've got a couple questions there.  First can/should it be done.  Anyone know if my parts/pieces will work well with Mach3. 
And last, just out of curiosity I see where I could probably use the ENA pins on the Galil system for the limit switches/servo drivers.  That would have been handy to use when troubleshooting as there are commands to stop run away servos.  Am I better to leave them connected directly to the drivers or is there value in moving them?  Another thing I've found is once the limit switch is tripped I can't seem to drive the servo in either direction.  I have to manually (no handwheels) move it off the limit switch.  Seems I should be able to 'drive' it in the direction that is off the limit switch.

Long and a lot of buried questions, sorry about that...I'm new to Galil.



Offline kcrouch

  •  193 193
  • In way too deep!!!
    • View Profile
Re: New (to me) Galil system, many questions
« Reply #1 on: March 04, 2013, 10:42:43 AM »
Try using the "BN" command to burn (save) the values to the Galil.
Having way too much fun! Something must surely be wrong.