Hello Guest it is December 15, 2019, 07:26:29 PM

Author Topic: Hanging on startup  (Read 1415 times)

0 Members and 1 Guest are viewing this topic.

Hanging on startup
« on: February 26, 2013, 09:29:27 PM »
Hi all,
I am new here.

Been using my Mach3 2.0 driven K2 for a couple years now with no issues. Starts up, loads programs, runs the balls.

After a couple months of ignoring it, I got around to using the system on Friday night to make some pattern boards for my quilt machine. Worked like a champ. Finished four boards, shut down mack3, shut down the laptop. Saturday afternoon went back out to do the last two boards. System booted. Started Mach3. Front splash screen came up. Then nothing. never transitioned to the operator screen.

So what I have done:
1.) Tried it a couple more times. Same behavior.
2.) Thinking i picked up a virus, I checked the memory stick for virus. The laptop itself is not connected to the internet. No Virus detected.
3.) Thinking maybe the EXE got corrupted, I downloaded version 3.xx (whatever the latest version is). Copied the directory so I wouldn't lose any information. Upgraded the software. Same behavior.
4.) Downloaded the Mach3 manual. Ran the driver test. Counted down to "2", then stopped. Hung the system.
5.) Tried different xml  setup files. No change.

When this thing hangs, it hangs the whole computer. The mouse and keyboard are locked out. Nothing to do but turn off the computer.
No other programs hang it. The task manager never comes up with the application but the launched thread shows Mach3 using about 45 to 55% of resources. The rest of the resources are spread over explorer, task manager, etc. Nothing really out of the ordinary.

Pretty frustrated. Any hints as to where to look?

tim in san jose
Re: Hanging on startup
« Reply #1 on: February 27, 2013, 08:33:47 AM »
Mine occasionaly does the same thing.
I switch everything off at the mains, wait 30 seconds, and then restart everything as I normally do and its usually ok. Have never found anything which causes it to freeze.
Graham
Re: Hanging on startup
« Reply #2 on: February 27, 2013, 02:15:18 PM »
Further investigation:
1.) Downloaded the Gecko G540 manual. Tested the watchdog system, disabled it and the controller appears to work fine. It looks like a pin 16 issue.
2.) So. I looked at the parallel setup in the laptop setup. it was set up for transmit only. Probably because the battery discharged all the way, losing the bios setup. Changed it back to two way communication... no change.
3.) The red red light on the gecko never changes when doing either the driver test or  initializing the Mach3 so it still looks like a communication issue.

Why would it hang the entire XP? Perhaps because it is attempting to take over the lower level IO functionality of the OS?

Any ideas are still appreciated. Will continue this forum blog thread for those who follow behind.

tim in san jose